Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160071 - Add patch to fix bad domains when doing NTLM authentication against an Exchange server
Summary: Add patch to fix bad domains when doing NTLM authentication against an Exchan...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsoup
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On: 159901
Blocks: FC3Update FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-06-10 16:25 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-26 21:56:20 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-06-10 16:25:36 UTC
+++ This bug was initially created as a clone of Bug #159901 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524
Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Upstream gnome bugs 302183 and 306877 report a problem (and a simple fix) when
doing NTLM authentication using libsoup (used by evolution-connector package to
talk to Exchnage servers).

Usernames of the form DOMAIN\USERNAME fail, due to libsoup getting confused
about the domain to supply to the server in the type 3 NTLM message.

There's a simple fix, which should be evaluated for a RHEL4 update.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See upstream bug  

Additional info:

Comment 1 Dave Malcolm 2005-06-10 16:30:57 UTC
and for FC3 and FC4...

Comment 2 Dave Malcolm 2005-06-30 03:51:51 UTC
libsoup-2.2.2-2.FC3 released as a test update for FC3 on June 16th
libsoup-2.2.3-4.FC4 released as a test update for FC4 on June 29th

Comment 3 Dave Malcolm 2005-08-26 20:30:38 UTC
I've submitted those packages for a Final update for FC3/FC4


Note You need to log in before you can comment on or make changes to this bug.