Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160069 - Tar hangs in D state on tape write.
Summary: Tar hangs in D state on tape write.
Keywords:
Status: CLOSED DUPLICATE of bug 160068
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 16:22 UTC by Pablo Mayrgundter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-24 01:14:26 UTC


Attachments (Terms of Use)

Description Pablo Mayrgundter 2005-06-10 16:22:42 UTC
Description of problem:

Tar hangs in D state on tape write, using Adaptec AHA-3960D SCSI card and Dell
PowerVault 122T.  I can't kill the process and can't 'ls /proc/[it's pid]/fd/'

Version-Release number of selected component (if applicable):

I'm using an FC3 system with kernel 2.6.11-1.14_FC3smp.

How reproducible:

Tar accepts a "-b" flag for the size of blocks to use in writing and reading. 
If I don't first set the tape drive to use a corresponding block size, tar hangs
immediate on invocations for read or write.  When I do set the corresponding
block sizes, the behavior becomes infrequent, but happens after about a day of
solid usage.

Steps to Reproduce:
1. tar cf /dev/tape files
2.
3.
  
Actual results:

Tar hangs.

Expected results:

Shouldn't hang.

Additional info:

Comment 1 Dave Jones 2005-06-24 01:14:26 UTC

*** This bug has been marked as a duplicate of 160068 ***


Note You need to log in before you can comment on or make changes to this bug.