Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600687 - fuse process segfault when use resolve-gids option
Summary: fuse process segfault when use resolve-gids option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 19:01 UTC by Vitaly Lipatov
Modified: 2018-10-23 15:13 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:13:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vitaly Lipatov 2018-07-12 19:01:33 UTC
Description of problem:

Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fdd79460fb5 in frame_fill_groups (frame=frame@entry=0x7fdd5800d880) at fuse-helpers.c:175
175	                ngroups = gf_getgrouplist (result->pw_name, frame->root->gid,
(gdb) bt
#0  0x00007fdd79460fb5 in frame_fill_groups (frame=frame@entry=0x7fdd5800d880) at fuse-helpers.c:175
#1  0x00007fdd7946140e in get_groups (frame=0x7fdd5800d880, priv=0x1b98340) at 

Version-Release number of selected component (if applicable):


It segfaults if there is no matching password record for uid and getpwuid_r  returns 0 and set result to NULL.

Comment 1 Worker Ant 2018-07-12 19:14:26 UTC
REVIEW: https://review.gluster.org/20499 (add check if no matching password record was found with getpwuid_r(uid)) posted (#1) for review on master by Vitaly Lipatov

Comment 2 Worker Ant 2018-07-13 13:04:03 UTC
COMMIT: https://review.gluster.org/20499 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- add check if no matching password record was found with getpwuid_r(uid)

Change-Id: Iae712828ee656008faf5fe2bc4e6f96fa12ea4cb
fixes: bz#1600687
Signed-off-by: Vitaly Lipatov <lav@etersoft.ru>

Comment 3 Shyamsundar 2018-10-23 15:13:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.