Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600679 - openshift-ansible 3.10 is creating a jenkins image stream pointing to v3.11
Summary: openshift-ansible 3.10 is creating a jenkins image stream pointing to v3.11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.10.z
Assignee: Ben Parees
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 18:35 UTC by Mike Fiedler
Modified: 2018-07-30 20:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Ansible bundled imagestream content from a future release was included in the v3.10 ansible installer Consequence: Some imagestream references that are installed with v3.10 will not be valid. Fix: Imagestream content was replaced with the correct v3.10 content. Result: Imagestream references will all be valid.
Clone Of:
Environment:
Last Closed: 2018-07-30 20:22:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2263 None None None 2018-07-30 20:22:54 UTC

Description Mike Fiedler 2018-07-12 18:35:13 UTC
Description of problem:

After installing 3.10.15 with openshift-ansible 3.10.15, the jenkins image stream points to:  registry.access.redhat.com/openshift3/jenkins-2-rhel7:v3.11

Verified that /usr/share/openshift/examples/image-streams/image-streams-rhel7.json on the master is incorrect as well



Version-Release number of selected component (if applicable): 3.10.15


How reproducible: Always


Steps to Reproduce:
1. Install 3.10.15
2. oc get imagestream jenkins -n openshift -o yaml

Actual results:

registry.access.redhat.com/openshift3/jenkins-2-rhel7:v3.11

Expected results:

registry.access.redhat.com/openshift3/jenkins-2-rhel7:v3.10

Comment 3 Scott Dodson 2018-07-19 12:40:24 UTC
In openshift-ansible-3.10.17-1 and later

Comment 4 Mike Fiedler 2018-07-19 12:45:37 UTC
Verified on 3.10.18 - image stream locations are correct.

registry.access.redhat.com/openshift3/jenkins-2-rhel7:v3.10

Comment 6 errata-xmlrpc 2018-07-30 20:22:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2263


Note You need to log in before you can comment on or make changes to this bug.