Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160067 - gnome-panel loses settings
Summary: gnome-panel loses settings
Keywords:
Status: CLOSED DUPLICATE of bug 160439
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 16:08 UTC by Kyle R Maxwell
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 16:40:36 UTC


Attachments (Terms of Use)

Description Kyle R Maxwell 2005-06-10 16:08:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
It appears that something is getting saved incorrectly to the gnome settings. I think it's just the panel (although the most recent recurrence lost my background setting, too). The result is that *nothing* shows up, either in the top panel (where the menus, notification areas, clock, etc. should be by default) or in the bottom panel (that should contain open windows and the workspace switcher). I tried archiving off the .gconf, .gconfd, .gnome, .gnome2, and .gnome2_private directories and deleting them, then restarting, but when I came back, most everything was restored: all the notifications and monitors I've added were there but the launchers were not (the menus and open window areas were restored). Trying to re-add anything by hand does not work.

Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-10

How reproducible:
Always

Steps to Reproduce:
1. Choose to save configuration.
2. Log out
3. Log back in
  

Additional info:

Comment 1 Kyle R Maxwell 2005-06-10 16:16:35 UTC
Hmm, not as straightforward as I thought. With a completely blown away config
(as described above), most recently it did not recur, though it did several
times before this.

I restored .gconf and .gconfd from the archive of my old config (ie without
.gnome, .gnome2, and .gnome2_private) and, other than the missing launchers, it
works now. So something was corrupted in there, I believe.

Comment 2 Mark McLoughlin 2005-06-22 15:52:13 UTC
If it happens again, try doing:

  gconftool-2 --config-source=xml:readonly:~/.gconf --direct --dump / > dump.xml

and attach it here.

Can't really do anything about the bug until we have some idea where the problem is.

Marking as WORKSFORME, but please do re-open with more details if you manage to
reproduce.

Comment 3 Kyle R Maxwell 2005-06-24 13:51:35 UTC
Recurring now on every login; running the above command produces:

Failed to load source "xml:readonly:~/.gconf": Couldn't resolve address for
configuration source: Bad address `xml:readonly:~/.gconf': `~' is an invalid
character in a configuration storage address

GConf-ERROR **: file gconftool.c: line 828 (main): assertion failed: (err == NULL)
aborting...
Trace/breakpoint trap


Comment 4 Mark McLoughlin 2005-06-27 16:40:36 UTC
Turns out this is a bug of bug #160439, I think

*** This bug has been marked as a duplicate of 160439 ***


Note You need to log in before you can comment on or make changes to this bug.