Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160059 - init script will not stop daemon if smb.conf deleted while running
Summary: init script will not stop daemon if smb.conf deleted while running
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba
Version: 4.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Simo Sorce
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 15:21 UTC by Chester Hosey
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-05 19:11:44 UTC


Attachments (Terms of Use)

Description Chester Hosey 2005-06-10 15:21:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
"/etc/init.d/smb stop" exits silently if smb.conf does not exist.

Version-Release number of selected component (if applicable):
samba-3.0.10-1.4E

How reproducible:
Always

Steps to Reproduce:
1. With existing /etc/samba/smb.conf, start samba (/etc/init.d/smb start).
2. Delete or rename /etc/samba/smb.conf
3. "/etc/init.d/smb stop" will exit silently.

Actual Results:  The script silently exits without stopping smbd.

Expected Results:  Service should be stopped.

Additional info:

Filed as low priority because this is not likely to happen often and an easy workaround is present (killall smbd nmbd).

Comment 1 RHEL Product and Program Management 2006-08-18 17:38:45 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Simo Sorce 2007-03-05 19:22:41 UTC
While smb.conf is the config file and not the init script itself, it is a
required comopnent of the package. Removing smb.conf is not considered a correct
operation.

If you think there is a situation in which removing smb.conf is necessary or
happens under some condition, please reopen the bug and describe in which
situation this may happen.



Note You need to log in before you can comment on or make changes to this bug.