Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600582 - flatpaks should pick the default browser to open http links
Summary: flatpaks should pick the default browser to open http links
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xdg-desktop-portal
Version: 7.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 14:26 UTC by Martin Krajnak
Modified: 2018-11-13 13:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-05 12:56:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Krajnak 2018-07-12 14:26:39 UTC
Description of problem:
I have 2 browsers installed Chrome and Firefox, if  I click on http link in libreoffice or hexchat, there is an xdg-open window asking which browser the link should be opened. This is annoying since the dialog is small and sometimes it remains hidden under some window somewhere in whole desktop, and there is no option like remember the selection or something similar.
So it would be nice if flatpaks just pick up the default browser. I've tested the non-flatpak app and they are picking the default browser without problems, although I am not 100% sure that this is caused by flatpak.

Version-Release number of selected component (if applicable):
flatpak-0.10.4-2.el7.x86_64
gnome-shell-3.28.2-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Have a http link inside libreoffice(flatpak) document or hexchat
2.Ctrl + Click the link in LO, Click the link in hexchat

Actual results:
Dialog window appears and you have to pick the browser, always, for every link

Expected results:
The link should be opened in the default browser

Additional info:

Comment 2 Martin Krajnak 2018-07-12 14:29:22 UTC
Please provide any additional information how to debug this if required, thanks.


Note You need to log in before you can comment on or make changes to this bug.