Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160045 - Squid no longer build with --enable-ident-lookups
Summary: Squid no longer build with --enable-ident-lookups
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squid
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 13:15 UTC by Sean E. Millichamp
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:08:20 UTC


Attachments (Terms of Use)

Description Sean E. Millichamp 2005-06-10 13:15:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.2-1.3.1 StumbleUpon/1.9993 Firefox/1.0.4

Description of problem:
Every RHEL 3 box I have deployed absolutely depends on Squid being build with --enable-ident-lookups for identd based access controls. 

Nowhere in the RHEL4 release notes did it say anything about the Squid build options being changed so that features present in RHEL3 would not be present in RHEL4.


Version-Release number of selected component (if applicable):
squid-2.5.STABLE6-3.4E.5

How reproducible:
Always

Steps to Reproduce:
1. /usr/sbin/squid -v
2. See '--disable-ident-lookups


Actual Results:  Squid Cache: Version 2.5.STABLE6
configure options:  --build=x86_64-redhat-linux --host=x86_64-redhat-linux 
--target=x86_64-redhat-linux-gnu --program-prefix= --prefix=/usr 
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc 
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com 
--mandir=/usr/share/man --infodir=/usr/share/info --exec_prefix=/usr 
--bindir=/usr/sbin --libexecdir=/usr/lib64/squid --localstatedir=/var 
--sysconfdir=/etc/squid --enable-poll --enable-snmp 
--enable-removal-policies=heap,lru --enable-storeio=aufs,coss,diskd,null,ufs 
--enable-ssl --with-openssl=/usr/kerberos --enable-delay-pools 
--enable-linux-netfilter --with-pthreads --enable-ntlm-auth-helpers=SMB,winbind 
--enable-external-acl-helpers=ip_user,ldap_group,unix_group,wbinfo_group,winbind_group 
--enable-auth=basic,ntlm --with-winbind-auth-challenge --enable-useragent-log 
--enable-referer-log --disable-dependency-tracking 
--enable-cachemgr-hostname=localhost --disable-ident-lookups --enable-truncate 
                                     ^^^^^^^^^^^^^^^^^^^^^^^
--enable-underscores --datadir=/usr/share 
--enable-basic-auth-helpers=LDAP,MSNT,NCSA,PAM,SMB,YP,getpwnam,multi-domain-NTLM,SASL,winbind


Expected Results:  I should either have been given warning in the RHEL 3 release notes that --enable-ident-lookups was deprecated and going away in a future release or RHEL 4 should never have disabled the feature.

In either case, it should have been clearly stated in the release notes.


Additional info:

Comment 1 Martin Stransky 2005-06-30 11:13:41 UTC

*** This bug has been marked as a duplicate of 161640 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:08:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.