Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600428 - Vmware Compute profile unable to save the enabling CD-Rom checkbox
Summary: Vmware Compute profile unable to save the enabling CD-Rom checkbox
Keywords:
Status: CLOSED DUPLICATE of bug 1566543
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - VMWare
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 08:35 UTC by Sanket Jagtap
Modified: 2018-08-01 19:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-01 19:40:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sanket Jagtap 2018-07-12 08:35:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a VMware Compute resource
2. Create a Compute Profile for the same
3. Check/Enable attaching CD-rom, and submit

Actual results:
No error on submit, but on revisiting the Compute profile , the checkbox is not checked

Expected results:
It should keep changes persistent

Additional info:

Comment 2 Sanket Jagtap 2018-07-12 08:40:20 UTC
Build: Satellite 6.3.0 snap 11

This is not a regression and also affects 6.3 builds

Comment 3 Chris Roberts 2018-08-01 15:36:22 UTC
Shows its being added correctly via the api and the db:

2018-08-01T11:34:09 [I|app|320b8]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"U+drJ4etnUQ/0kpZWeclkJZTBO9LTbKRJi/mlQcS3H2ObRq2knonIB+aW841SZIcUJhfeIpCKfGmV8X7kdCEqg==", "compute_attribute"=>{"vm_attrs"=>{"cpus"=>"1", "corespersocket"=>"1", "memory_mb"=>"2048", "firmware"=>"bios", "cluster"=>"Satellite_Engineering", "resource_pool"=>"Resources", "path"=>"/Datacenters/RH_Engineering/vm/Satellite-Engineering", "guest_id"=>"rhel7_64Guest", "hardware_version"=>"Default", "memoryHotAddEnabled"=>"0", "cpuHotAddEnabled"=>"0", "add_cdrom"=>"1", "annotation"=>"", "scsi_controllers"=>"{\"scsiControllers\":[{\"type\":\"VirtualLsiLogicController\",\"key\":1000}],\"volumes\":[{\"thin\":true,\"name\":\"Hard disk\",\"mode\":\"persistent\",\"controllerKey\":1000,\"size\":10485760,\"sizeGb\":10,\"storagePod\":\"Synology-Cluster\"}]}", "interfaces_attributes"=>{"0"=>{"type"=>"VirtualVmxnet3", "network"=>"network-106"}}}}, "commit"=>"Submit", "compute_profile_id"=>"1-1-Small", "id"=>"1"}



foreman=# select * from compute_attributes;
 id | compute_profile_id | compute_resource_id |           name            |                                  vm_attrs                                  |         created_at         |         updated_at         
----+--------------------+---------------------+---------------------------+----------------------------------------------------------------------------+----------------------------+----------------------------
  1 |                  1 |                   1 | 1 CPUs and 2048 MB memory | --- !ruby/hash:ActiveSupport::HashWithIndifferentAccess                   +| 2018-08-01 15:33:02.396174 | 2018-08-01 15:34:09.415333
    |                    |                     |                           | cpus: '1'                                                                 +|                            | 
    |                    |                     |                           | corespersocket: '1'                                                       +|                            | 
    |                    |                     |                           | memory_mb: '2048'                                                         +|                            | 
    |                    |                     |                           | firmware: bios                                                            +|                            | 
    |                    |                     |                           | cluster: Satellite_Engineering                                            +|                            | 
    |                    |                     |                           | resource_pool: Resources                                                  +|                            | 
    |                    |                     |                           | path: "/Datacenters/RH_Engineering/vm/Satellite-Engineering"              +|                            | 
    |                    |                     |                           | guest_id: rhel7_64Guest                                                   +|                            | 
    |                    |                     |                           | hardware_version: Default                                                 +|                            | 
    |                    |                     |                           | memoryHotAddEnabled: '0'                                                  +|                            | 
    |                    |                     |                           | cpuHotAddEnabled: '0'                                                     +|                            | 
    |                    |                     |                           | add_cdrom: '1'                                                            +|                            | 
    |                    |                     |                           | annotation: ''                                                            +|                            | 
    |                    |                     |                           | scsi_controllers:                                                         +|                            | 
    |                    |                     |                           | - !ruby/hash:ActiveSupport::HashWithIndifferentAccess                     +|                            | 
    |                    |                     |                           |   type: VirtualLsiLogicController                                         +|                            | 
    |                    |                     |                           |   key: 1000                                                               +|                            | 
    |                    |                     |                           | interfaces_attributes: !ruby/hash:ActiveSupport::HashWithIndifferentAccess+|                            | 
    |                    |                     |                           |   '0': !ruby/hash:ActiveSupport::HashWithIndifferentAccess                +|                            | 
    |                    |                     |                           |     type: VirtualVmxnet3                                                  +|                            | 
    |                    |                     |                           |     network: network-106                                                  +|                            | 
    |                    |                     |                           | volumes_attributes: !ruby/hash:ActiveSupport::HashWithIndifferentAccess   +|                            | 
    |                    |                     |                           |   '0': !ruby/hash:ActiveSupport::HashWithIndifferentAccess                +|                            | 
    |                    |                     |                           |     thin: true                                                            +|                            | 
    |                    |                     |                           |     name: Hard disk                                                       +|                            | 
    |                    |                     |                           |     mode: persistent                                                      +|                            | 
    |                    |                     |                           |     controller_key: 1000                                                  +|                            | 
    |                    |                     |                           |     size: 10485760                                                        +|                            | 
    |                    |                     |                           |     size_gb: 10                                                           +|                            | 
    |                    |                     |                           |     storage_pod: Synology-Cluster                                         +|                            | 
    |                    |                     |                           |                                                                            |                            |

Comment 4 Chris Roberts 2018-08-01 19:40:45 UTC

*** This bug has been marked as a duplicate of bug 1566543 ***


Note You need to log in before you can comment on or make changes to this bug.