Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160039 - Garbage characters on console when switching to hu_HU locale
Summary: Garbage characters on console when switching to hu_HU locale
Keywords:
Status: CLOSED DUPLICATE of bug 167363
Alias: None
Product: Fedora
Classification: Fedora
Component: kbd
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 11:33 UTC by Smela Csaba
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-27 14:02:16 UTC


Attachments (Terms of Use)

Description Smela Csaba 2005-06-10 11:33:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu-HU; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
Switching to a non-unicode locale (hu_HU) by modifying i18n as LANG="hu_HU" SYSFONT="lat2-16" typing any hungarian accent character "garbage" characters are displayed . Looks like unicode encoded letters trying to be displayed on a non-unicode terminal. Running unicode_start those characters are displayed correctly but Midnight Commander is awfull.



Version-Release number of selected component (if applicable):
bash-3.0-31

How reproducible:
Always

Steps to Reproduce:
1. Change settings in i18n
2. Open a terminal and type some hungarian accent letters.
3. 
  

Actual Results:  Garbage chars are displayed on terminal.

Expected Results:  Correct ones should be seen.

Additional info:

Ssh terminals thru putty work great.

Switching to non-unicode hungarian works fine in both FC3 and RHEL4.

Comment 1 Tim Waugh 2005-06-10 12:01:26 UTC
What terminal program are you using, which is displaying garbage characters?

Comment 2 Smela Csaba 2005-06-10 13:09:36 UTC
Standard tty. VGA monitor attached to the video card of my computer. You just
boot  and login on root's or any other's account. Tried to switch terminal by
ALT+F2 - F6. Same happens. 

Accessing over ssh from remote linux is OK. 

Comment 3 Smela Csaba 2005-06-10 13:24:23 UTC
Listing directory contents by ls -l all hungarian chars are correct. Only input
characters typed from console's keyboard look garbage. 

Comment 4 Dave Jones 2005-06-27 23:14:55 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.

Comment 5 Smela Csaba 2005-06-28 08:43:17 UTC
Netinstalled fc4 final.
Yum updated.
Repeated steps mentioned above.

Nothing has changed. Problem still exists.

Comment 6 Jens Petersen 2005-09-27 12:57:59 UTC
Reassigning to kbd.

Comment 7 Miloslav Trmač 2005-09-27 14:02:16 UTC

*** This bug has been marked as a duplicate of 167363 ***


Note You need to log in before you can comment on or make changes to this bug.