Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600387 - Dnf python3.7 errors.
Summary: Dnf python3.7 errors.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 07:05 UTC by edpil02
Modified: 2018-09-27 13:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 13:29:24 UTC


Attachments (Terms of Use)

Description edpil02 2018-07-12 07:05:28 UTC
Cant install some packages since dnf python 3.7 rebuilt.


--> bash-4.4$ sudo dnf install insight

Total                                                                                                                 333 kB/s | 7.9 MB     00:24     
/usr/lib/python3.7/site-packages/dnf/cli/cli.py:231: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working
  if not isinstance(display, collections.Sequence):

Test de la transaction en cours
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
Les paquets téléchargés ont été mis en cache jusqu’à la prochaine transaction réussie.
Vous pouvez supprimer les paquets en cache en exécutant « dnf clean packages ».
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 123, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 154, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 234, in do_transaction
    super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 904, in do_transaction
    self._run_transaction(cb=cb)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 974, in _run_transaction
    tid = self.history.beg(rpmdbv, using_pkgs, [], cmdline)
  File "/usr/lib/python3.7/site-packages/dnf/db/history.py", line 448, in beg
    int(misc.getloginuid())
  File "/usr/lib64/python3.7/site-packages/libdnf/transaction.py", line 739, in beginTransaction
    return _transaction.Swdb_beginTransaction(self, dtBegin, rpmdbVersionBegin, cmdline, userId)
RuntimeError: C++ std::exception: Step: FOREIGN KEY constraint failed in
INSERT INTO   rpm VALUES   (6031, 'insight', 0, '8.1.50.20180216', '4.fc29', 'x86_64')
bash-4.4$ 


No issue when using a gui (dnfdragora or apper)

Comment 1 Daniel Mach 2018-07-16 11:31:34 UTC
It's most likely relate

Comment 2 Jan Kurik 2018-08-14 09:53:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Jaroslav Mracek 2018-09-27 13:29:24 UTC
I believe that the problem is fixed in dnf-3.6.1 where a lot of issues with swdb were fixed.


Note You need to log in before you can comment on or make changes to this bug.