Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160036 - No SNMP match: 'RICOH Aficio 2228C'
Summary: No SNMP match: 'RICOH Aficio 2228C'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: foomatic
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 09:20 UTC by Didier Couderc
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: 3.0.2-20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-13 17:37:12 UTC


Attachments (Terms of Use)
/usr/share/foomatic/db/source/printer/Ricoh-Aficio_2228C_PS.xml (deleted)
2005-06-10 13:13 UTC, Tim Waugh
no flags Details

Description Didier Couderc 2005-06-10 09:20:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
Trying to configure new printer with system-config-printer. It's a Ricoh Aficio
2228C.  After specifying "Networked JetDirect" and the IP address, the following message is displayed :
No SNMP match: 'RICOH Aficio 2228C'
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

PS: There is a ppd file available for this printer on linuxprinting.org

Version-Release number of selected component (if applicable):
foomatic-3.0.2-3

How reproducible:
Always

Steps to Reproduce:
1.start system-config-printer
2.select New
3.select 'Networked JetDirect' and enter IP address for printer
  

Additional info:

Comment 1 Tim Waugh 2005-06-10 13:13:12 UTC
Created attachment 115290 [details]
/usr/share/foomatic/db/source/printer/Ricoh-Aficio_2228C_PS.xml

Please save this file and copy it to:

  /usr/share/foomatic/db/source/printer/Ricoh-Aficio_2228C_PS.xml

Is the printer model now automatically selected from the list?

Comment 2 Didier Couderc 2005-06-13 07:10:24 UTC
I copied the file to the specified location, set permissions on it. I even
rebooted (kernel update). I still have the exact same message
  No SNMP match: 'RICOH Aficio 2228C'
  Please report this message in Bugzilla:
    https://bugzilla.redhat.com/bugzilla
  Choose 'foomatic' as the component.
repeated 4 times.

Using 'ls -lu' I see that the file is accessed when I run system-config-printer
but it doesn't seem to be recognized.


Comment 3 Tim Waugh 2005-06-13 10:59:31 UTC
Please paste this into a terminal and let me know what it says:

cat <<EOF > test.py
#!/usr/bin/python
import sys
sys.path.append("/usr/share/printconf/util")
from printconf_conf import *
foomatic_init_overview()
print foomatic.snmp_dict['RICOH Aficio 2228C'].id
m=foomatic.make_model_dict_dict['Ricoh']['Aficio 2228C PS']
print m.snmp_description
EOF
python test.py



Comment 4 Didier Couderc 2005-06-13 11:39:00 UTC
I ran the test. Here is the output :
Called : foomatic_init_overview()
Traceback (most recent call last):
  File "test.py", line 6, in ?
    print foomatic.snmp_dict['RICOH Aficio 2228C'].id
KeyError: 'RICOH Aficio 2228C'


Comment 5 Tim Waugh 2005-06-13 17:37:12 UTC
Ah, this is because there was no XML file there in the first place.  Sorry, I
had thought I was giving you an updated version of an aleady-existing file.

Well, this is fixed in the development code (tested locally).  The message
itself is harmless.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.