Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160027 - saxexts.py:74:_create_parser:raise _exceptions.SAXReaderNotAvailable
Summary: saxexts.py:74:_create_parser:raise _exceptions.SAXReaderNotAvailable
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: PyXML
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 04:43 UTC by tfeis
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:00:54 UTC


Attachments (Terms of Use)

Description tfeis 2005-06-10 04:43:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.3) Gecko/20040803

Description of problem:
When I open redhat-network-config,Exception occured and crush dump is displayed and say it is a most likely bug. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start
2.System setting
3.Network setting
  

Additional info:

Component: redhat-config-network
Version: 1.2.63
Summary: TB93195e3c saxexts.py:74:_create_parser:TypeError: __init__() takes at least 2 arguments (1 given)
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 187, in ?
    from netconfpkg import NC_functions
  File "/usr/src/build/439899-noarch/install/usr/share/redhat-config-network/netconfpkg/__init__.py", line 41, in ?
  File "/usr/lib/python2.2/site-packages/rhpl/genClass.py", line 994, in GenClass_read_classfile
    __GenClass_read_classfile(boxpath, mod, OptLower)
  File "/usr/lib/python2.2/site-packages/rhpl/genClass.py", line 947, in __GenClass_read_classfile
    doc = xml.dom.minidom.parse(boxpath)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/minidom.py", line 962, in parse
    return _doparse(pulldom.parse, args, kwargs)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/minidom.py", line 953, in _doparse
    events = apply(func, args, kwargs)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/pulldom.py", line 338, in parse
    parser = xml.sax.make_parser()
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/sax2exts.py", line 37, in make_parser
    return XMLParserFactory.make_parser(parser_list)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 64, in make_parser
    return self._create_parser(parser_name)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 43, in _create_parser
    return drv_module.create_parser()
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 74, in _create_parser
    raise _exceptions.SAXReaderNotAvailable
TypeError: __init__() takes at least 2 arguments (1 given)

Local variables in innermost frame:

Comment 1 Harald Hoyer 2005-06-10 10:15:34 UTC
It seems you removed some important system components manually or some files are
corrupted. Due to the traceback, I reassign this bug to PyXML.

Comment 3 Harald Hoyer 2005-07-21 07:47:09 UTC
Please attach the output of:

# rpm -Vv PyXML redhat-config-network

Comment 4 tfeis 2005-07-22 10:59:49 UTC
(In reply to comment #3)
> Please attach the output of:
> # rpm -Vv PyXML redhat-config-network

No output is displayed. 
# rpm -Vv PyXML redhat-config-network
#                                             <----no message

Comment 5 Harald Hoyer 2005-07-22 13:43:30 UTC
no messages? hmm..
# rpm -q PyXML redhat-config-network

??

Comment 6 tfeis 2005-07-24 03:27:25 UTC
(In reply to comment #5)
> no messages? hmm..
> # rpm -q PyXML redhat-config-network
> ??

Hello,

# rpm -q PyXML redhat-config-network
PyXML-0.7.1-9
redhat-config-network-1.2.63-1
#


Comment 7 RHEL Product and Program Management 2007-10-19 19:00:54 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.