Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160026 - gcc crashes when compiling the latest wine
Summary: gcc crashes when compiling the latest wine
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
: 160807 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 03:58 UTC by Glen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-13 15:19:53 UTC


Attachments (Terms of Use)
The preprocessed source that crashes gcc. (deleted)
2005-06-10 04:04 UTC, Glen
no flags Details


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 22013 None None None Never

Description Glen 2005-06-10 03:58:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When trying to compile the latest version of wine, checked out via cvs, gcc spits out the following:

gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__   -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith  -g -O2 -o dialog.o dialog.c
dialog.c: In function msi_dialog_scrolltext_control:
dialog.c:516: internal compiler error: in gimple_add_tmp_var, at gimplify.c:532
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccqgw4pc.out file, please attach this to your bugreport.
make[2]: *** [dialog.o] Error 1
make[2]: Leaving directory `/home/decker/projects/wine-build/dlls/msi'
make[1]: *** [msi] Error 2
make[1]: Leaving directory `/home/decker/projects/wine-build/dlls'
make: *** [dlls] Error 2

Version-Release number of selected component (if applicable):
4.0.0-11

How reproducible:
Always

Steps to Reproduce:
1. Try and compiler the latest version of wine.
2.
3.
  

Actual Results:  Gcc crashes.

Expected Results:  I expected gcc to compile wine.

Additional info:

Comment 1 Glen 2005-06-10 04:04:20 UTC
Created attachment 115283 [details]
The preprocessed source that crashes gcc.

Comment 2 Hans Kristian Rosbach 2005-06-10 07:14:00 UTC
I can second this error.

gcc-4.0.0-11 and yesterdays wine cvs produces crashes.

Comment 3 Jakub Jelinek 2005-06-17 13:29:12 UTC
*** Bug 160807 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.