Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160024 - GAL access fails authentication
Summary: GAL access fails authentication
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector
Version: 4.0
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard: RHEL4U3NAK
Depends On: 160023
Blocks: 170416
TreeView+ depends on / blocked
 
Reported: 2005-06-10 03:15 UTC by Dave Malcolm
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-21 16:26:00 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-06-10 03:15:12 UTC
+++ This bug was initially created as a clone of Bug #160023 +++

Description of problem:
Appears to be the same problem shown here
http://bugzilla.gnome.org/show_bug.cgi?id=269611
If I use user@domain, GAL will not work, calendars do work.

If I switch to domain\user, neither the GAL nor the calendars work.

Everything else seems to work OK.

The patch for this was committed to the 2.0.3 branch, but appears not to have
made it to the Fedora tree.

Backend is Exchange 2003 on Windows 2003 server, GC on a Windows 2000 domain
controller.  OWA is using forms-based authentication with SSL.

Version-Release number of selected component (if applicable):
2.0.4-1, 2.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. Authenticate using user@domain method
2. Attempt to perform GAL lookup (contact list, new message auto-complete, etc.)

  
Actual results:
Setting E2K_DEBUG=4 shows

GC: Connecting to ldap://<my GC server>:3268/   
** (evolution-exchange-storage:12585): WARNING **: LDAP authentication 
failed (0x31)   

Expected results:
Authentication should work with either user@domain or domain\user.

Additional info:

Comment 1 Dave Malcolm 2005-06-18 00:33:36 UTC
Works for me on RHEL4 with: 
evolution-2.0.2-8
evolution-connector-2.0.2-5

with usernames of the form: domain\username with NTLM authentication to an
Exchange 2003 on Windows Server 2003

Possibly a problem with FBA?

Comment 3 Frank Pineau 2005-06-20 16:06:14 UTC
Domain controller and GAL server is a separate Windows 2000 machine.  Exchange
2003 running on a Windows 2K3 machine.  Are you authenticating against a Win2K3
DC that is also running Exchange 2003?  Looking at the Gnome bug, maybe it's an
issue with passing user@domain authentication information to a Win2000 DC.

Comment 10 RHEL Product and Program Management 2006-07-21 16:26:01 UTC
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.