Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600180 - DVR: Inter Tenant Traffic between two networks and connected through a shared network not reachable with DVR routers
Summary: DVR: Inter Tenant Traffic between two networks and connected through a shared...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 10.0 (Newton)
Assignee: Brian Haley
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-11 15:31 UTC by Brian Haley
Modified: 2019-01-16 17:11 UTC (History)
8 users (show)

Fixed In Version: openstack-neutron-9.4.1-31.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 17:11:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1751396 None None None 2018-07-11 15:32:01 UTC
Launchpad 1783654 None None None 2018-09-04 14:49:02 UTC
OpenStack gerrit 578112 None None None 2018-07-11 15:34:49 UTC
Red Hat Product Errata RHBA-2019:0080 None None None 2019-01-16 17:11:20 UTC

Description Brian Haley 2018-07-11 15:31:57 UTC
Cloned from launchpad bug 1751396.

Description:

Inter Tenant Traffic between Two Tenants on two different private networks connected through a common shared network (created by Admin) is not route able through DVR routers

Steps to reproduce it:

(NOTE: No external, just shared network)
This is only reproducable in Multinode scenario. ( 1 Controller - 2 compute ).
Make sure that the two VMs are isolated in two different computes.

openstack network create --share shared_net

openstack subnet create shared_net_sn --network shared_net --subnet-range 172.168.10.0/24


openstack network create net_A
openstack subnet create net_A_sn --network net_A --subnet-range 10.1.0.0/24


openstack network create net_B
openstack subnet create net_B_sn --network net_B --subnet-range 10.2.0.0/24


openstack router create router_A

openstack port create --network=shared_net --fixed-ip subnet=shared_net_sn,ip-address=172.168.10.20 port_router_A_shared_net
openstack router add port router_A port_router_A_shared_net
openstack router add subnet router_A net_A_sn

openstack router create router_B
openstack port create --network=shared_net --fixed-ip subnet=shared_net_sn,ip-address=172.168.10.30 port_router_B_shared_net
openstack router add port router_B port_router_B_shared_net
openstack router add subnet router_B net_B_sn

openstack server create server_A --flavor m1.tiny --image cirros --nic net-id=net_A
openstack server create server_B --flavor m1.tiny --image cirros --nic net-id=net_B
  
Add static routes to the router.
openstack router set router_A --route destination=10.1.0.0/24,gateway=172.168.10.20
openstack router set router_B --route destination=10.2.0.0/24,gateway=172.168.10.30
```

Ping from one instance to the other times out

Specification URL (additional information):

https://bugs.launchpad.net/neutron/+bug/1751396

Comment 8 Alex 2018-09-03 08:00:26 UTC
Hi there,

If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field.

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Thanks,
Alex

Comment 9 Brian Haley 2018-09-04 14:48:37 UTC
This will not need doc text as the change has to be reverted as it causes other problems.

https://code.engineering.redhat.com/gerrit/#/c/149165/

Comment 21 errata-xmlrpc 2019-01-16 17:11:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0080


Note You need to log in before you can comment on or make changes to this bug.