Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160016 - net-snmp returns 100mbps as max speed for e1000 1gbps interface
Summary: net-snmp returns 100mbps as max speed for e1000 1gbps interface
Keywords:
Status: CLOSED DUPLICATE of bug 152480
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-10 00:57 UTC by rambler8
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-10 17:36:23 UTC


Attachments (Terms of Use)

Description rambler8 2005-06-10 00:57:22 UTC
Description of problem:

     net-snmp shows the max speed of a e1000 interface connected at 1gbps to 
only be 100mbps

Version-Release number of selected component (if applicable):

     net-snmp-5.1.2-11
     net-snmp-libs-5.1.2-11
     net-snmp-utils-5.1.2-11
     kernel-smp-2.6.9-5.0.5.EL

How reproducible:

     Everytime

Steps to Reproduce:
1. install rpms listed in version section on a machine with an e1000 NIC 
(actually mine has 3 of them, eth0 connected at 100mbps, eth1 no connected, 
eth2 connected at 1gbps)
2. connect the e1000 NIC to a hub or switch at 1gbps
3. confirm speed of NIC interface with ethtool
4. configure snmp to allow queries and provide interface information with OID 
IF-MIB::ifSpecific.4 = OID: SNMPv2-SMI::zeroDotZero
5. run snmpwalk and note the ifSpeed value for the e1000 1gbps interface
    
Actual results:

     IF-MIB::ifSpeed.4 = Gauge32: 100000000

Expected results:

     IF-MIB::ifSpeed.4 = Gauge32: 1000000000

Additional info:

  oids in snmpd.conf:

     view    networkview   included    .1.3.6.1.2.1.1
     view    networkview   included    .1.3.6.1.2.1.2
     view    networkview   included    .1.3.6.1.2.1.4.20
     view    networkview   included    .1.3.6.1.2.1.25.1.1

  output from ethtool eth2:

        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: umbg
        Wake-on: d
        Current message level: 0x00000007 (7)
        Link detected: yes

  Related Output from snmpwalk:

        IF-MIB::ifIndex.4 = INTEGER: 4
        IF-MIB::ifDescr.4 = STRING: eth2
        IF-MIB::ifType.4 = INTEGER: ethernetCsmacd(6)
        IF-MIB::ifMtu.4 = INTEGER: 1500
        IF-MIB::ifSpeed.4 = Gauge32: 100000000
        IF-MIB::ifPhysAddress.4 = STRING: 0:11:43:ce:e4:af
        IF-MIB::ifAdminStatus.4 = INTEGER: up(1)
        IF-MIB::ifOperStatus.4 = INTEGER: up(1)
        IF-MIB::ifInOctets.4 = Counter32: 2003471
        IF-MIB::ifInUcastPkts.4 = Counter32: 26915
        IF-MIB::ifInDiscards.4 = Counter32: 0
        IF-MIB::ifInErrors.4 = Counter32: 0
        IF-MIB::ifOutOctets.4 = Counter32: 2002244
        IF-MIB::ifOutUcastPkts.4 = Counter32: 26895
        IF-MIB::ifOutDiscards.4 = Counter32: 0
        IF-MIB::ifOutErrors.4 = Counter32: 0
        IF-MIB::ifOutQLen.4 = Gauge32: 0
        IF-MIB::ifSpecific.4 = OID: SNMPv2-SMI::zeroDotZero

Comment 1 Radek Vokal 2005-06-10 17:36:23 UTC
This bug will be fixed in RHEL4-U2

*** This bug has been marked as a duplicate of 152480 ***

Comment 2 rambler8 2005-06-11 04:05:48 UTC
Why is access to bug 152480 restricted? Please remove access restrictions.

Comment 3 Radek Vokal 2005-06-13 07:05:29 UTC
It's internal feature request. 


Note You need to log in before you can comment on or make changes to this bug.