Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600155 - ceph-mgr modules not enabled on mimic
Summary: ceph-mgr modules not enabled on mimic
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.1
Assignee: Guillaume Abrioux
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-11 14:31 UTC by Guillaume Abrioux
Modified: 2018-07-24 20:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-24 20:12:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2784 None None None 2018-07-11 14:33:03 UTC
Github ceph ceph-ansible pull 2875 None None None 2018-07-11 14:37:55 UTC

Description Guillaume Abrioux 2018-07-11 14:31:20 UTC
Description of problem:
The data structure regarding mgr modules state has slightly changed from mimic.

Prior to mimic, it used to be:

```
{
    "enabled_modules": [
        "status"
    ],
    "disabled_modules": [
        "balancer",
        "dashboard",
        "influx",
        "localpool",
        "prometheus",
        "restful",
        "selftest",
        "zabbix"
    ]
}
```

From mimic it looks like this:

```
{
    "enabled_modules": [
        "status"
    ],
    "disabled_modules": [
        {
            "name": "balancer",
            "can_run": true,
            "error_string": ""
        },
        {
            "name": "dashboard",
            "can_run": true,
            "error_string": ""
        }
    ]
}
```

This means we can't simply check if `item` is in `item in
_ceph_mgr_modules.disabled_modules`

Steps to Reproduce:
1. Set ceph_mgr_modules to [status]
2. Deploy a mimic cluster (so all modules are disabled but 'status')
3. Set ceph_mgr_modules to [status,iostat] (so you are going to enable a new mgr module)
4. Relaunch ceph-ansible

Actual results:
mgr modules are not enabled

Expected results:
mgr modules are enabled

Comment 3 Ken Dreyer (Red Hat) 2018-07-23 21:32:53 UTC
will be in the next upstream stable-3.1 tag after v3.1.0rc10


Note You need to log in before you can comment on or make changes to this bug.