Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600084 - bison FTBFS in rhel-7.6
Summary: bison FTBFS in rhel-7.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bison
Version: 7.6
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Patsy Franklin
QA Contact: Edjunior Barbosa Machado
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-11 11:43 UTC by Edjunior Barbosa Machado
Modified: 2018-10-30 11:46 UTC (History)
3 users (show)

Fixed In Version: bison-3.0.4-2.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-10-30 11:46:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
bison-3.0.4-1.el7.src.rpm rebuild log in rhel-7.6 x86_64 (deleted)
2018-07-11 11:43 UTC, Edjunior Barbosa Machado
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3307 None None None 2018-10-30 11:46:41 UTC

Description Edjunior Barbosa Machado 2018-07-11 11:43:06 UTC
Created attachment 1458051 [details]
bison-3.0.4-1.el7.src.rpm rebuild log in rhel-7.6 x86_64

Description of problem:
bison-3.0.4-1.el7.src.rpm fails to build from source in rhel-7.6.

Adding gcc-c++ as BuildRequires seems to solve this problem.

Version-Release number of selected component (if applicable):
bison-3.0.4-1.el7.src.rpm

How reproducible:
100%

Steps to Reproduce:
1. yum-builddep -y bison-3.0.4-1.el7.src.rpm
2. rpmbuild --rebuild bison-3.0.4-1.el7.src.rpm


Actual results:
# rpmbuild --rebuild bison-3.0.4-1.el7.src.rpm
(...)
Making all in .
make[5]: Entering directory `/root/rpmbuild/BUILD/bison-3.0.4'
  GEN      doc/bison.help
make[5]: Leaving directory `/root/rpmbuild/BUILD/bison-3.0.4'
make[4]: Leaving directory `/root/rpmbuild/BUILD/bison-3.0.4'
./tests/testsuite -C tests 
make[3]: *** [check-local] Error 77
make[3]: Leaving directory `/root/rpmbuild/BUILD/bison-3.0.4'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/root/rpmbuild/BUILD/bison-3.0.4'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/root/rpmbuild/BUILD/bison-3.0.4'
make: *** [check] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.1AL4RW (%check)


RPM build errors:
    bison-3.0.4-1.el7.src.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    user mockbuild does not exist - using root
    group mockbuild does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.1AL4RW (%check)

Expected results:
Successful build

Additional info:

Comment 2 Edjunior Barbosa Machado 2018-07-13 14:27:01 UTC
Verified as fixed on bison-3.0.4-2.el7.src.rpm

Comment 6 errata-xmlrpc 2018-10-30 11:46:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3307


Note You need to log in before you can comment on or make changes to this bug.