Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160007 - Invalid desktop file (MIME, category) in qgo
Summary: Invalid desktop file (MIME, category) in qgo
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qgo
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Ricker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-09 23:20 UTC by Kevin Kofler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.0.1-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-25 19:17:19 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2005-06-09 23:20:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; H010818)

Description of problem:
Problem 1. The MIME type entry in fedora-qgo.desktop is invalid and causes update-desktop-database to complain (and apparently to refuse to complete its job, because new entries only appear in the menu after removing the invalid MIME type).
Problem 2. fedora-qgo.desktop is also missing a category. The only category set is X-Fedora. It should be in the Games category.

Version-Release number of selected component (if applicable):
qgo-1.0.1-3.fc3

How reproducible:
Always

Steps to Reproduce:
Problem 1. Try running update-desktop-database after installing qgo and notice how you get an error.
Problem 2. Look for qgo in the Games section of the menu (I'm using KDE, but I don't think it's any different in GNOME) and notice it isn't there. Check the desktop file and notice how there is no category set other than X-Fedora.  

Additional info:

Here's the error message from update-desktop-database for the first problem:
# update-desktop-database
File '/usr/share/applications/fedora-qgo.desktop' contains invalid MIME type 'Application' that is missing a slash

Comment 1 Chris Ricker 2005-06-13 04:02:40 UTC
qgo-1.0.1-5.fc3 is building now, which should fix both of these errors

Comment 2 Kevin Kofler 2005-06-19 01:57:23 UTC
This is indeed fixed in qgo-1.0.1-5.fc3, but not in qgo-1.0.1-5.fc4, which 
still suffers from both of these problems.

Comment 3 Chris Ricker 2005-06-25 19:17:19 UTC
very odd, since 1.0.1-5.fc3 and 1.0.1-5.fc4 are the same spec ;-). When I built
1.0.1-5.fc4 locally it fixed it, but when it built in the build system it didn't....

At any rate, I've pushed a new build (1.0.1-6) for FC4 and for rawhide that
fixes it in a more fool-proof way. Thanks!


Note You need to log in before you can comment on or make changes to this bug.