Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1600026 - [cephmetrics] Containerised grafana-server.service is being restarted after executing iptables -F
Summary: [cephmetrics] Containerised grafana-server.service is being restarted after e...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Metrics
Version: 3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.1
Assignee: ceph-eng-bugs
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-11 08:59 UTC by sagrawal
Modified: 2018-07-11 11:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-11 11:43:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description sagrawal 2018-07-11 08:59:21 UTC
Description of problem:
In the containerised scenario, when the dashboard was not reflecting the changes [Ref: https://bugzilla.redhat.com/show_bug.cgi?id=1599996], after the restart of grafana-server.service, the dashboard was not being displayed.
Then after executing iptables -F command on ceph cluster nodes, the grafana-server.service is being restarted every 8-10 seconds.

Version-Release number of selected component (if applicable):
ceph-ansible: 3.1.0-0.1.rc9.el7cp
cephmetrics-ansible: 2.0-1.el7cp
ceph version 12.2.5-27.el7cp (6b7d1a8cf2e2376fd0a12424947c8c97aa1c0890) luminous (stable)


How reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual results:The grafana-server.service should not restart and the ceph-metrics dashboard should be displayed.


Expected results: The grafana-server.service is being restarted and the ceph-metrics dashboard is not displayed.


Additional info:

Comment 3 Boris Ranto 2018-07-11 11:43:04 UTC
We talked about this on IRC. You need to refresh the deployment after updating the cluster configuration. Dropping the firewall rules made the grafana container fail because it was not able to access the internet. Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.