Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160002 - Evolution crashed when replying to an e-mail with an special UTF character in the subject
Summary: Evolution crashed when replying to an e-mail with an special UTF character in...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution
Version: 4.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Depends On:
Blocks: 170416
TreeView+ depends on / blocked
 
Reported: 2005-06-09 23:04 UTC by Taco Scargo
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-21 16:26:23 UTC


Attachments (Terms of Use)
Backtrace of crashing evolution (deleted)
2005-08-25 20:01 UTC, Taco Scargo
no flags Details

Description Taco Scargo 2005-06-09 23:04:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
When replying to a message with a UTF character in it, after clicking "send" the program crashes and the message is not sent or saved.

Version-Release number of selected component (if applicable):
evolution-2.0.2-16

How reproducible:
Always

Steps to Reproduce:
1. Send yourself an e-mail with the following subject "=?UTF-8?B?57+9?="
2. After receiving the e-mail, click reply and then send

  

Actual Results:  Evolution crashes, message has not been sent and is lost

Expected Results:  Message should have been sent

Additional info:

Comment 1 Dave Malcolm 2005-06-18 00:26:29 UTC
Works for me; what mail transport is this with?

Can you obtain a backtrace?

Comment 2 Dave Malcolm 2005-06-18 00:27:28 UTC
(I was testing with evolution-2.0.2-8 and the Exchange connector, though)

Comment 3 Taco Scargo 2005-06-19 15:04:27 UTC
I am using evolution-2.0.2-16 and using smtp as mail transport.

How do I 'obtain a backtrace' ?

Comment 5 Dave Malcolm 2005-06-24 21:43:22 UTC
Information on obtaining a backtrace can be found here (this page applies to
Fedora, but is almost entirely applicable to RHEL):
http://fedora.linux.duke.edu/wiki/StackTraces


Comment 6 Taco Scargo 2005-08-25 20:01:24 UTC
Created attachment 118119 [details]
Backtrace of crashing evolution

Please note I was not able to copy the third line after "Thread 1" (so the line
that starts with in=0xc78380). I had to manually type it in. Maybe a hidden
character ???

Comment 7 Taco Scargo 2005-08-26 07:30:39 UTC
Additional info: when clicking forward the application crashes as well, but this
time immediately. The backtrace was generated by clicking the forward button in
the toolbar.

Comment 9 Dave Malcolm 2005-10-18 19:28:33 UTC
Which locale are you running evolution in?

Comment 10 Taco Scargo 2005-10-19 07:53:10 UTC
English (USA)

Comment 16 RHEL Product and Program Management 2006-07-21 16:26:23 UTC
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.