Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159996 - system-config-netboot gui corrupting diskless image definitions
Summary: system-config-netboot gui corrupting diskless image definitions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot
Version: 4.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 145411 156322
TreeView+ depends on / blocked
 
Reported: 2005-06-09 22:24 UTC by brian
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2005-484
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 13:47:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:484 qe-ready SHIPPED_LIVE Updated system-config-netboot package 2005-10-05 04:00:00 UTC

Description brian 2005-06-09 22:24:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
When using the gui tool to define a diskless image with its name, description, server ip, path and the selecting the kernel to use, if you later go back and edit this definition and say change its description but nothing else the result is the definition gets changed from a diskless to a kickstart install image.

Version-Release number of selected component (if applicable):
all up to system-config-netboot-0.1.17-1.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Define diskless image with name, description, server, path to export and kernel
2.Close the diskless image window
3.Open the diskless image window
4.Highlight the image you just made and select edit
5.Alter the description of the image (ie nothing of importance)
6.Complete the edit and close the window.
  

Actual Results:  The image you defined in the diskless image window disapears from that window upon looking for it later.  But if you go into the install image window it is now there.  Also if you look at the /tftpboot/linux-install/pxelinux.cfg/pxeos.xml file you can see it no longer is setup to be a diskless definition but now has things set to be a kickstart install image.

Expected Results:  The only thing that should have changed is the description and the image should have stayed as a diskless image definition.

Additional info:

I would also note that if you by intent or accident name multiple diskless and or install images the same that things get mixed up and it always seems to use the first one listed in the pxeos.xml file.  We noted this before we understood what was happening to our images that kept disapearing form the diskless image screen, as they became install images.  If we kept the same name things always seemed to get routed back to that first broken image that became an install image.

Comment 1 brian 2005-06-10 06:27:04 UTC
Sorry for the close/reopen of the bug report.  The defaults of the web page
caught me off guard and it defaulted to close as resolved with "not a bug" as label.

Comment 2 Jason Vas Dias 2005-06-14 00:18:31 UTC
This is now fixed with system-config-netboot-0.1.18-1 , which should 
be in RHEL-4-U2, but which meanwhile can be downloaded from:
http://people.redhat.com/~jvdias/system-config-netboot
s-c-nb no longer will convert pxe os entries from diskless to installs,
and will not allow you to use the name of an existing OS entry when 
creating a new OS entry.
Please try out the new version and let me know of any issues - 
thank you!


Comment 3 brian 2005-06-14 20:05:40 UTC
After retrying this new version the bug I was seeing is not happening now. 
Thanks for getting the quick fix for this. :)

Comment 6 Red Hat Bugzilla 2005-10-05 13:47:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-484.html



Note You need to log in before you can comment on or make changes to this bug.