Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1599749 - Updating libvirt-daemon failed to complete properly
Summary: Updating libvirt-daemon failed to complete properly
Keywords:
Status: CLOSED DUPLICATE of bug 1558648
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-10 13:42 UTC by David Hill
Modified: 2018-07-10 13:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-10 13:53:40 UTC


Attachments (Terms of Use)

Description David Hill 2018-07-10 13:42:22 UTC
Description of problem:

Updating libvirt-daemon failed to complete properly

/var/tmp/rpm-tmp.kELC2x: line 6: virtlogd.socket: command not found
error: %preun(libvirt-daemon-4.1.0-1.fc29.x86_64) scriptlet failed, exit status 127
Error in PREUN scriptlet in rpm package libvirt-daemon
Error in PREUN scriptlet in rpm package libvirt-daemon
error: libvirt-daemon-4.1.0-1.fc29.x86_64: erase failed

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 David Hill 2018-07-10 13:46:28 UTC
Failed:
  libvirt-daemon-4.1.0-1.fc29.x86_64

Comment 2 Jiri Denemark 2018-07-10 13:53:40 UTC
Per https://bugzilla.redhat.com/show_bug.cgi?id=1558648#c5
the package with the broken script needs to be removed manually:
rpm -e --noscripts libvirt-daemon-4.1.0-1.fc29

*** This bug has been marked as a duplicate of bug 1558648 ***


Note You need to log in before you can comment on or make changes to this bug.