Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159969 - Sound-Juicer rips whole cd for each track selected
Summary: Sound-Juicer rips whole cd for each track selected
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
: 160377 160378 160380 160382 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-09 19:51 UTC by Brian Pepple
Modified: 2013-03-13 04:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 20:29:53 UTC


Attachments (Terms of Use)
Patch from Ubuntu package (deleted)
2005-06-28 20:00 UTC, David Nielsen
no flags Details | Diff

Description Brian Pepple 2005-06-09 19:51:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Sound-Juicer rips the whole cd for each track selected.  For example, if the album has ten tracks, it will rip the whole album into a each individual ogg file.  I've experienced this with 4 albums in a row, to verify that it wasn't due to a faulty cd.

Version-Release number of selected component (if applicable):
sound-juicer-2.10.1-1

How reproducible:
Always

Steps to Reproduce:
1. Insert cd
2. Select all tracks
3. Hit extract button
  

Actual Results:  Each ogg file contains the whole album.

Expected Results:  Individual ogg files should only contain their respective track.

Additional info:

Sound-Juicer worked fine the last time I used it (May 22nd), and since there hasn't been a new release I'm guessing one of it's dependent modules (maybe gstreamer) must be causing this behavior.

Comment 1 John (J5) Palmieri 2005-06-09 19:58:08 UTC
Can you supply the version of gstreamer you have installed?

Comment 2 Brian Pepple 2005-06-09 20:05:58 UTC
I'm using:

gstreamer-0.8.10-1
gstreamer-plugins-0.8.9-1

Comment 3 John (J5) Palmieri 2005-06-09 20:09:37 UTC
It is most likely a gstreamer plugins issue as I just updated that in rawhide
yesterday.  Might be awhile until I can get to debugging this.  For now you
might want to downgrade to 0.8.8 if you need the functionality.

Comment 4 John (J5) Palmieri 2005-06-14 20:36:58 UTC
*** Bug 160380 has been marked as a duplicate of this bug. ***

Comment 5 John (J5) Palmieri 2005-06-14 20:37:12 UTC
*** Bug 160382 has been marked as a duplicate of this bug. ***

Comment 6 John (J5) Palmieri 2005-06-14 20:37:30 UTC
*** Bug 160378 has been marked as a duplicate of this bug. ***

Comment 7 John (J5) Palmieri 2005-06-14 20:37:57 UTC
*** Bug 160377 has been marked as a duplicate of this bug. ***

Comment 8 David Nielsen 2005-06-14 21:43:20 UTC
I'm sorry about the duplicate bugreports, something went wrong.. I guess I'm
just dumb.

Comment 9 David Nielsen 2005-06-25 19:33:44 UTC
The upstream bug is:
http://bugzilla.gnome.org/show_bug.cgi?id=307031

the bug appears fixed in CVS

Comment 10 John (J5) Palmieri 2005-06-28 19:41:13 UTC
gnome.org servers are being moved so I can't get the patch yet.  When they come
back online I will make sure to apply the patch and build another rpm.

Comment 11 David Nielsen 2005-06-28 20:00:29 UTC
Created attachment 116084 [details]
Patch from Ubuntu package

I picked this patch up from the Ubuntu package, hopefully it fixes the issue

Comment 12 John (J5) Palmieri 2005-07-06 20:29:53 UTC
This should be fixed in rawhide

Comment 13 David Nielsen 2005-07-06 20:35:51 UTC
confirmed, I owe you beer John


Note You need to log in before you can comment on or make changes to this bug.