Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1599629 - Don't execute statements after decrementing call count in afr
Summary: Don't execute statements after decrementing call count in afr
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1598663
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-10 08:48 UTC by Pranith Kumar K
Modified: 2018-07-30 19:02 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1598663
Environment:
Last Closed: 2018-07-30 19:02:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2018-07-10 08:48:24 UTC
+++ This bug was initially created as a clone of Bug #1598663 +++

Description of problem:
    When call_count is decremented by one thread, another thread can
    go ahead with the operation leading to undefined behavior for the
    thread executing statements after decrementing call count.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-07-06 04:39:53 EDT ---

REVIEW: https://review.gluster.org/20470 (cluster/afr: Prevent execution of code after call_count decrementing) posted (#1) for review on master by Pranith Kumar Karampuri

--- Additional comment from Worker Ant on 2018-07-10 04:47:13 EDT ---

COMMIT: https://review.gluster.org/20470 committed in master by "Pranith Kumar Karampuri" <pkarampu@redhat.com> with a commit message- cluster/afr: Prevent execution of code after call_count decrementing

Problem:
When call_count is decremented by one thread, another thread can
go ahead with the operation leading to undefined behavior for the
thread executing statements after decrementing call count.

Fix:
Do the operations necessary before decrementing call count.

fixes bz#1598663
Change-Id: Icc90cd92ac16e5fbdfe534d9f0a61312943393fe
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>

Comment 1 Worker Ant 2018-07-10 08:50:39 UTC
REVIEW: https://review.gluster.org/20486 (cluster/afr: Prevent execution of code after call_count decrementing) posted (#1) for review on release-4.1 by Pranith Kumar Karampuri

Comment 2 Worker Ant 2018-07-23 23:41:14 UTC
COMMIT: https://review.gluster.org/20486 committed in release-4.1 by "Pranith Kumar Karampuri" <pkarampu@redhat.com> with a commit message- cluster/afr: Prevent execution of code after call_count decrementing

Problem:
When call_count is decremented by one thread, another thread can
go ahead with the operation leading to undefined behavior for the
thread executing statements after decrementing call count.

Fix:
Do the operations necessary before decrementing call count.

fixes bz#1599629
Change-Id: Icc90cd92ac16e5fbdfe534d9f0a61312943393fe
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
(cherry picked from commit 03f1f5bdc46076178f1afdf8e2a76c5b973fe11f)

Comment 3 Shyamsundar 2018-07-30 19:02:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.1.2, please open a new bug report.

glusterfs-4.1.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-July/000106.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.