Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1599518 - logging mux certificate error
Summary: logging mux certificate error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.z
Assignee: Simo Sorce
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-10 02:11 UTC by Rajnikant
Modified: 2018-08-03 15:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-03 15:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rajnikant 2018-07-10 02:11:12 UTC
Description of problem:
logging mux certificate error
Unable to create logging-mux certs
Fluentd error looks like
---
2018-07-02 09:40:16 +0000 [info]: reading config file path="/etc/fluent/fluent.conf"
2018-07-02 09:40:16 +0000 [warn]: 'block' action stops input process until the buffer full is resolved. Check your pipeline this action is fit or not
2018-07-02 09:40:16 +0000 [error]: config error file="/etc/fluent/fluent.conf" error="no valid certificates in cert_path: /etc/fluent/muxkeys/cert"
----

Version-Release number of selected component (if applicable):
3.6

How reproducible:
Yes,

Steps to Reproduce:
1. Deploy logging EFK with mux, logging-mux pods was in crashloopback 
2. Uninstall logging EFK
 ansible-playbook -e openshift_logging_install_logging=false  /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/openshift-logging.yml

The certs folder in master /etc/origin/logging is not deleted. So when redeploying EFK with mux,the certs are not created again.
3.

After uninstalling EFK with playbook,need to remove manually "logging" folder /etc/origin in master and redeployed EFK, post that logging-mux pods was running.

Actual results:
---
2018-07-02 09:40:16 +0000 [info]: reading config file path="/etc/fluent/fluent.conf"
2018-07-02 09:40:16 +0000 [warn]: 'block' action stops input process until the buffer full is resolved. Check your pipeline this action is fit or not
2018-07-02 09:40:16 +0000 [error]: config error file="/etc/fluent/fluent.conf" error="no valid certificates in cert_path: /etc/fluent/muxkeys/cert"
----


Expected results:
Should be installed

Additional info:

Comment 2 Jeff Cantrill 2018-07-10 13:11:02 UTC
Noriko, please investigate


Note You need to log in before you can comment on or make changes to this bug.