Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159942 - gaim-meanwhile hangs when connecting to Sametime server
Summary: gaim-meanwhile hangs when connecting to Sametime server
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim-meanwhile
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Josh Boyer
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-09 14:58 UTC by Kyle R Maxwell
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-07-28 23:34:18 UTC

Attachments (Terms of Use)
Output of 'gaim -d' (deleted)
2005-06-10 15:14 UTC, Kyle R Maxwell
no flags Details

Description Kyle R Maxwell 2005-06-09 14:58:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Additional version information:

While connecting to my corporate Sametime server, gaim freezes upon attempting to log in. The last message seen during the connection process is "Waiting for login acknowledgment", after which the connection window disappears and the buddy list window goes blank; I have to perform a force quit. Additionally, I installed the debuginfo RPMs and tried to follow the instructions at but to no avail, as the following gdb output shows:

$ gdb gaim
GNU gdb Red Hat Linux (
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db library "/lib/".

(gdb) run
Starting program: /usr/bin/gaim
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x3db000
[Thread debugging using libthread_db enabled]
[New Thread -1208740160 (LWP 3516)]
Detaching after fork from child process 3519.
Couldn't get registers: No such process.
(gdb)     thread apply all bt
Cannot find new threads: generic error
(gdb) bt
Cannot fetch general-purpose registers for thread -1208740160: generic error

However, when I try to reproduce the problem as root (and hence need to create a new profile in gaim), I'm able to log in successfully. I also should note that the same versions worked OK yesterday, so it's possible that gaim or meanwhile somehow corrupted something in my settings.

I have not yet been able to update to the more current upstream packages for testing due to a maintenance outage at

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start gaim
2. Choose to login to Sametime profile


Additional info:

Comment 1 Kyle R Maxwell 2005-06-09 21:13:43 UTC
I moved my .gaim to a backup directory and restarted gaim to create the account
from scratch. This time, I was able to get a stack trace:

Thread 1 (Thread -1208793408 (LWP 8418)):
#0  0x6c656966 in ?? ()
#1  0x00cac6fb in mwConversation_free () from /usr/lib/
#2  0x00ca378b in mwService_free () from /usr/lib/
#3  0x009da456 in mw_prpl_close (gc=0x90cde58) at mwgaim.c:2457
#4  0x00e9c3cd in serv_close (gc=0x90cde58) at server.c:126
#5  0x00e813b5 in gaim_connection_disconnect (gc=0x90cde58) at connection.c:241
#6  0x00e775be in gaim_account_disconnect (account=0x90d0970) at account.c:246
#7  0x00e81306 in gaim_connection_disconnect (gc=0x90cde58) at connection.c:228
#8  0x00e814c5 in gaim_connection_disconnect_cb (data=0x90d0970)
    at connection.c:282
#9  0x002daf06 in g_main_context_wakeup () from /usr/lib/
#10 0x002d93ee in g_main_context_dispatch () from /usr/lib/
#11 0x002dc3f6 in g_main_context_check () from /usr/lib/
#12 0x002dc6e3 in g_main_loop_run () from /usr/lib/
#13 0x010481b5 in gtk_main () from /usr/lib/
#14 0x00f0eebe in main (argc=1, argv=0xbfb4c214) at main.c:961

Further, I believe the problem may actually lie upstream as I have a report here
of someone using gaim and meanwhile on a Windows system and seeing the same
problem. But the fact that it worked for me when I ran as root tells me it's not
just site-specific.

Comment 2 Josh Boyer 2005-06-09 23:18:46 UTC
I need to get a rawhide system up and running before I can try to recreate this.
 I'll talk with the upstream meanwhile folks and see if it's a known issue in
the meantime.

Thanks for the report.  Stay tuned.

Comment 3 Christopher O'Brien 2005-06-10 13:59:29 UTC
Please try to get the debugging output from gaim by running `gaim -d` This
should provide some insight as to what's happening leading up to the hang and crash.

Also, try using the 'Force Login' option. Start gaim as `gaim -n` to prevent it
from automatically logging on, then go to preferences and select the 'Meanwhile'
options on the bottom-left to get to the plugin's preferences.

Comment 4 Kyle R Maxwell 2005-06-10 15:14:29 UTC
Created attachment 115291 [details]
Output of 'gaim -d'

Here's the 'gaim -d' output as requested.

Using the 'force login' option does let me connect, after all. So now I have a
workaround; I'll see if it works for my Windows user also, although I notice
that the version of gaim I have on Windows doesn't have that option.

Comment 5 Kyle R Maxwell 2005-06-10 16:54:04 UTC
My Windows user upgraded to gaim-meanwhile-1.2.3 and it works for him. So maybe
we just need a version bump?

Comment 6 Josh Boyer 2005-06-10 23:19:56 UTC
Hm, I requested a build for 1.2.3 a while ago...  seems stuck in the build
system somewhere.  I'll dig around and see if I can get it pushed out.

Comment 7 Josh Boyer 2005-06-12 20:08:02 UTC
Ok, gaim-meanwhile-1.2.3-1.fc5 should be available in the Extras development
repository.  Please upgrade and give this a shot.

Comment 8 Kyle R Maxwell 2005-06-14 13:37:51 UTC
First day back in the office. Post-upgrade, without the "force login" option
turned on, the same behavior is still seen (ie gaim process hangs).

Comment 9 Christopher O'Brien 2005-07-12 05:29:31 UTC
I think I have this fixed in gaim-meanwhile CVS, however I've only been able to
test it with a mockup of a redirecting server since I don't have access to a
system that issues actual redirects. Would you be willing to test a CVS snapshot?

Comment 10 Kyle R Maxwell 2005-07-12 14:42:36 UTC
No problem, though it might be a day or two. Where can I get it?

Comment 11 Josh Boyer 2005-07-12 15:18:50 UTC
I'll grab CVS tonight and spin up an RPM.  I'll post it's location as soon as I
get it built.

Comment 12 Josh Boyer 2005-07-12 18:10:49 UTC
Ok, there are test RPMs built on gaim-meanwhile CVS at:


I was able to log into a non-redirecting with ST server with the RPM.  Please
test it out when you get a chance.

Comment 13 Josh Boyer 2005-07-14 17:07:00 UTC
Kyle, let us know if this works for you when you get a chance.  If so, then I
think the upstream developers will be releasing 1.2.4 soon.

Comment 14 Kyle R Maxwell 2005-07-14 19:21:45 UTC
Turned off workaround option, it still works - WFM now.

Comment 15 Christopher O'Brien 2005-07-14 21:48:58 UTC
just dropped gaim-meanwhile 1.2.4 on the world (upstream). Thanks!

Comment 16 Josh Boyer 2005-07-15 04:10:20 UTC
Updated in CVS.  I submitted builds, but the build server for Extras is
currently being worked on.  As soon as it's back up and running, the update
should be available

Comment 17 Josh Boyer 2005-07-28 23:34:18 UTC
The Fedora Core 3 and 4 builds have been released, and the development build has
completed successfully.  It should be pushed out soon.

Thanks for the help on this one.

Note You need to log in before you can comment on or make changes to this bug.