Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159941 - Bad kernel page request
Summary: Bad kernel page request
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-09 14:52 UTC by Kyle Ellrott
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 16:03:47 UTC


Attachments (Terms of Use)

Description Kyle Ellrott 2005-06-09 14:52:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
From messages

Jun  9 09:00:28 localhost kernel: Unable to handle kernel paging request at virtual address 4eeb2764
Jun  9 09:00:28 localhost kernel:  printing eip:
Jun  9 09:00:28 localhost kernel: c01c75d3
Jun  9 09:00:28 localhost kernel: *pde = 00000000
Jun  9 09:00:28 localhost kernel: Oops: 0000 [#1]
Jun  9 09:00:28 localhost kernel: Modules linked in: parport_pc lp parport autofs4 rfcomm l2cap bluetooth sunrpc ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables reiserfs dm_mod video button battery ac md5 ipv6 ohci1394 ieee1394 ohci_hcd ehci_hcd i2c_nforce2 i2c_core shpchp snd_intel8x0 snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc forcedeth floppy ext3 jbd sata_nv libata sd_mod scsi_mod
Jun  9 09:00:28 localhost kernel: CPU:    0
Jun  9 09:00:28 localhost kernel: EIP:    0060:[<c01c75d3>]    Not tainted VLI
Jun  9 09:00:28 localhost kernel: EFLAGS: 00010206   (2.6.11-1.1369_FC4)
Jun  9 09:00:28 localhost kernel: EIP is at proc_lookup+0x2d/0x96
Jun  9 09:00:28 localhost kernel: eax: 00000003   ebx: 4eeb2760   ecx: 00000003   edx: cd533cd0
Jun  9 09:00:28 localhost kernel: esi: cd533d51   edi: ddfcfaad   ebp: 00000004   esp: d587add4
Jun  9 09:00:28 localhost kernel: ds: 007b   es: 007b   ss: 0068
Jun  9 09:00:28 localhost kernel: Process multiload-apple (pid: 3530, threadinfo=d587a000 task=d3973000)
Jun  9 09:00:28 localhost kernel: Stack: 00000004 cd533cd0 ddeb4ddc ddeb4ddc d587af54 cd533cd0 d587ae80 c01c2bc0
Jun  9 09:00:28 localhost kernel:        c03cf200 cd533cd0 ddeb4ddc c018d9d7 d587af54 ddeb4e64 00000000 d587af54
Jun  9 09:00:28 localhost kernel:        d587ae8c d587ae80 c018dd99 ddfe40e0 01c5a71f d587ae8c d587ae80 d6a9c00a
Jun  9 09:00:28 localhost kernel: Call Trace:
Jun  9 09:00:28 localhost kernel:  [<c01c2bc0>] proc_root_lookup+0x47/0x51
Jun  9 09:00:28 localhost kernel:  [<c018d9d7>] real_lookup+0xb8/0xd7
Jun  9 09:00:28 localhost kernel:  [<c018dd99>] do_lookup+0x75/0x8f
Jun  9 09:00:28 localhost kernel:  [<c018e639>] __link_path_walk+0x886/0x117d
Jun  9 09:00:28 localhost kernel:  [<c036ce43>] unix_stream_sendmsg+0x285/0x36a
Jun  9 09:00:28 localhost kernel:  [<c018ef73>] link_path_walk+0x43/0xdb
Jun  9 09:00:28 localhost kernel:  [<c017a975>] get_unused_fd+0x79/0x1d2
Jun  9 09:00:28 localhost kernel:  [<c018d367>] getname+0x87/0xc5
Jun  9 09:00:28 localhost kernel:  [<c018f219>] path_lookup+0x76/0x149
Jun  9 09:00:28 localhost kernel:  [<c018f9ad>] open_namei+0x90/0x592
Jun  9 09:00:28 localhost kernel:  [<c017a71d>] filp_open+0x27/0x46
Jun  9 09:00:28 localhost kernel:  [<c017a975>] get_unused_fd+0x79/0x1d2
Jun  9 09:00:28 localhost kernel:  [<c018d367>] getname+0x87/0xc5
Jun  9 09:00:28 localhost kernel:  [<c017adcb>] sys_open+0x31/0x5b
Jun  9 09:00:28 localhost kernel:  [<c0103a51>] syscall_call+0x7/0xb
Jun  9 09:00:28 localhost kernel: Code: 56 53 83 ec 0c 89 44 24 08 89 54 24 04 8b 40 fc 85 c0 74 73 8b 58 34 85 db 74 6c 8b 44 24 04
8b 68 2c eb 07 8b 5b 2c 85 db 74 5c <0f> b7 43 04 39 e8 75 f1 8b 54 24 04 8b 72 30 8b 43 08 fc 39 ed
Jun  9 09:02:53 localhost syslogd 1.4.1: restart.


Version-Release number of selected component (if applicable):
kernel 2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Start computer
2. log in
3. wait a few minutes
  

Actual Results:  System locks up.  Running programs seem to function, but new programs can't be lauched.

Additional info:

Kernel 2.6.11-1.1286_FC4 seems to be perfectly functional.


Note You need to log in before you can comment on or make changes to this bug.