Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1599386 - Unable to install package due to missing dependency
Summary: Unable to install package due to missing dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: golang-github-prometheus-common
Version: 29
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Fridolín Pokorný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-09 16:34 UTC by Steve Miller
Modified: 2018-08-14 21:08 UTC (History)
5 users (show)

Fixed In Version: golang-github-prometheus-common-0-0.15.20180702git38c53a9.fc29 golang-github-prometheus-common-0-0.15.20180702git38c53a9.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-14 21:08:59 UTC


Attachments (Terms of Use)

Description Steve Miller 2018-07-09 16:34:57 UTC
Description of problem:
Unable to install package due to missing dependency

$ sudo dnf install 'golang(github.com/prometheus/common/model)'
Last metadata expiration check: 2:22:19 ago on Mon 09 Jul 2018 10:08:03 AM EDT.
Error: 
 Problem: conflicting requests
  - nothing provides golang(github.com/go-kit/kit/log) needed by golang-github-prometheus-common-devel-0-0.14.20180702git38c53a9.fc29.noarch
  - nothing provides golang(github.com/go-kit/kit/log/level) needed by golang-github-prometheus-common-devel-0-0.14.20180702git38c53a9.fc29.noarch


OR

$ sudo dnf install golang-github-prometheus-common-devel
Last metadata expiration check: 2:22:54 ago on Mon 09 Jul 2018 10:08:03 AM EDT.
Error: 
 Problem: conflicting requests
  - nothing provides golang(github.com/go-kit/kit/log) needed by golang-github-prometheus-common-devel-0-0.14.20180702git38c53a9.fc29.noarch
  - nothing provides golang(github.com/go-kit/kit/log/level) needed by golang-github-prometheus-common-devel-0-0.14.20180702git38c53a9.fc29.noarch

Version-Release number of selected component (if applicable): 0-0.14.20180702git38c53a9.fc29.noarch


How reproducible:


Steps to Reproduce:
1. Use Fedora Rawhide
2. Use DNF to try to install golang-github-prometheus-common-devel OR 'golang(github.com/prometheus/common/model)'

Actual results: Will not install


Expected results: Package to be able to be installed


Additional info:

Comment 1 Robert-André Mauchin 2018-07-09 19:04:00 UTC
Paul Gier, you've made the last update which seems to be missing golang(github.com/go-kit/kit/log), would you package it?

Comment 2 Paul Gier 2018-07-10 19:36:10 UTC
I can package it but it looks like go-kit has quite a few dependencies so it will take some time.  For short term, I'm wondering if we can remove the dependency on go-kit because it's only needed if the project is using the promlog package.

Comment 3 Fabio Valentini 2018-08-02 16:30:15 UTC
Can the fix also be pushed to f28, please? The dependency is still broken there:

> nothing provides golang(github.com/go-kit/kit/log) needed by golang-github-prometheus-common-devel-0-0.14.20180702git38c53a9.fc28.noarch

Comment 4 Fedora Update System 2018-08-03 10:46:32 UTC
golang-github-prometheus-common-0-0.15.20180702git38c53a9.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-838e7d0d95

Comment 5 Fedora Update System 2018-08-03 21:59:22 UTC
golang-github-prometheus-common-0-0.15.20180702git38c53a9.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-838e7d0d95

Comment 6 Jan Kurik 2018-08-14 11:24:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 7 Fedora Update System 2018-08-14 21:08:59 UTC
golang-github-prometheus-common-0-0.15.20180702git38c53a9.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.