Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159932 - hplip missing dependencies
Summary: hplip missing dependencies
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hpijs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-09 13:36 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.9.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-09 15:39:30 UTC


Attachments (Terms of Use)
This patch fixes my rpm build problem (deleted)
2005-06-09 15:21 UTC, Sammy
no flags Details | Diff

Description Sammy 2005-06-09 13:36:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.1 (like Gecko)

Description of problem:
In my particular case I did not have PyQt package installed, which failed the toolbox. 
Need dependence for this, sip, sane, etc. 
 
PS: The source rpm does not build these packages...seems like a bogus spec file. 

Version-Release number of selected component (if applicable):
hplip-0.9.3-0.1

How reproducible:
Always

Steps to Reproduce:
1. install hplip without PyQt  
2. /usr/share/hplip/toolbox 
3.  
    

Additional info:

Comment 1 Tim Waugh 2005-06-09 14:15:16 UTC
Oops, I thought I had fixed that but obviously it got lost between my test
package and actually committing to CVS.

Fixed in CVS.

Requires: PyQt added, and this brings in sip.

> PS: The source rpm does not build these packages...seems like a bogus spec
> file. 

I think you must be referring to the fact that hplip is not listed in the
components in bugzilla.  I'll see about fixing that.

Comment 2 Sammy 2005-06-09 14:37:46 UTC
No....actually the spec file from source rpm is incomplete. For example it
calls desktop-utils on a .desktop file which does not exist. The source
does not contain any desktop files and in Mardriva spec file the desktop file
is created in the spec file itself, so I don't see how this source rpm produced
the installed rpms!

Comment 3 Tim Waugh 2005-06-09 14:44:05 UTC
# rpm -ql hplip|grep desktop
/usr/share/applications/HP-hplip.desktop
/usr/share/hplip/data/hplip.desktop

It really is in the tarball, if you look closely.

Comment 4 Sammy 2005-06-09 15:12:37 UTC
It is generated in the Makefile .... BUT there are two options depending
on what the configure script assigns to ICON_FILE variable. If this is
assigned hplip.desktop then it creates a hplip.desktop file. If it is
assigned just hplip then it creates a file called hplip. In my case when
the configure runs it is setting ICON_FILE to hplip and thus not generating
a hplip.desktop file. I could not figure out the code in the configure
script that assigns this variable and why it gives different answers. I do
not have GNOME stuff installed just KDE.

Comment 5 Sammy 2005-06-09 15:21:13 UTC
Created attachment 115263 [details]
This patch fixes my rpm build problem

The attached patched fixes the problem. In principle this should also be fixed
in configure.in file.

Comment 6 Tim Waugh 2005-06-09 15:27:05 UTC
Can you try just changing this line (further down):

   jdx=$jdx=1

to:

   jdx=$jdx+1

That looks like a typo to me, and might be causing the probems you are seeing.

Comment 7 Tim Waugh 2005-06-09 15:30:56 UTC
Actually, why do you have a /usr/lib/menu directory in the first place?  What
does 'rpm -qf /usr/lib/menu' say?

Comment 8 Sammy 2005-06-09 15:38:10 UTC
No....doing that did not fix the problem.

I did have an empty /usr/lib/menu directory that does not belong to any rpm.

OK.... if I don't have /usr/lib/menu than it works without the patch!
Thanks!

Comment 9 Tim Waugh 2005-06-09 15:39:30 UTC
Well, anyway I'll apply that patch for 0.9.3-1.


Note You need to log in before you can comment on or make changes to this bug.