Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159928 (modprobe-o) - modprobe gives "Operation not permitted" when trying to load a module with a different name (via the -o option)
Summary: modprobe gives "Operation not permitted" when trying to load a module with a ...
Keywords:
Status: CLOSED NOTABUG
Alias: modprobe-o
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-09 12:46 UTC by udas
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-09 14:50:22 UTC


Attachments (Terms of Use)

Description udas 2005-06-09 12:46:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2) Gecko/20040308

Description of problem:
Here's a screenshot:
[root@vcslinux5 ~]# modprobe -o myhe he
FATAL: Error inserting he (/lib/modules/2.6.9-5.ELsmp/kernel/drivers/atm/he.ko): Operation not permitted
[root@vcslinux5 ~]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant)
[root@vcslinux5 ~]# uname -a
Linux vcslinux5.vxindia.veritas.com 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:30:39 EST
2005 i686 i686 i386 GNU/Linux
[root@vcslinux5 ~]#

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just run:
modprobe -o <some-custom-name> <modulename>
  

Actual Results:  "Operation not permitted" is returned

Expected Results:  The module should have loaded with the given name silently

Additional info:

Comment 1 Bill Nottingham 2005-06-09 14:50:22 UTC
This is because of the module signing in the kernel; renaming the module breaks
the signature.


Note You need to log in before you can comment on or make changes to this bug.