Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159906 - less fails to view non-ascii characters in utf-8 encoding
Summary: less fails to view non-ascii characters in utf-8 encoding
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: less
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 23:30 UTC by Ryan
Modified: 2013-07-02 23:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 11:37:29 UTC


Attachments (Terms of Use)

Description Ryan 2005-06-08 23:30:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
By default FC3 system is set up to use utf-8 encoding, but the program "less" is not set up correctly by default. When viewing a text file with non-ascii characters, less gives garbage output.

Version-Release number of selected component (if applicable):
less-382-4

How reproducible:
Always

Steps to Reproduce:
1.echo 哈哈 > test
2.less test
  

Actual Results:  <E5><93><88><E5><93><88>

Expected Results:  &#21704;&#21704;

Additional info:

Append a line to /etc/profile.d/less.sh will solve this problem in my case:
LESSCHARSET="utf-8"
Not sure about less.csh

Comment 1 Jindrich Novy 2005-07-04 10:01:45 UTC
Sorry, I cannot reproduce that with less-382-4 with LANG=en_US.UTF-8.
What's your value of LANG?

Comment 2 Ryan 2005-07-05 00:48:55 UTC
Sorry, I don't have access to that FC3 box any longer. Acording to what I 
remember, I'm using the default ( which should be en_US.UTF-8 ) with LC_CTYPE 
changed to zh_CN.UTF-8 ( set in /etc/sysconfig/i18n ). Notice that 
the "&#21704;" thing is one single Chinese character I typed in with SCIM 
input method but seems RH Bugzilla doesn't accept that. Is this miss leading 
you?

Comment 3 Jindrich Novy 2005-07-08 11:37:29 UTC
I had no problems testing less with the chinese characters with LANG=en_US.UTF-8
and LC_CTYPE=zh_CN.UTF-8 on my FC3 box. I saw the chinese characters perfectly
and still don't see anything bad with it so I'm closing this NOTABUG.

Please don't hesitate to reopen it if you find a better way how to reproduce it.

Thanks,
Jindrich


Note You need to log in before you can comment on or make changes to this bug.