Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159904 - parted crashes with assertion message during OS install
Summary: parted crashes with assertion message during OS install
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 22:40 UTC by Mike A. Harris
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 14:58:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike A. Harris 2005-06-08 22:40:10 UTC
Description of problem:
While installing RHEL4U1 RC (RHEL4-U1-re0525.0-i386-AS-DVD-ftp.iso), which
passes mediacheck correctly, I had a problem while partitioning using
disk druid.

My system has 3 OSs already installed:

- Windows XP (SP2)
- Fedora Core 2 (i386)
- Fedora Core 2 (x86_64)

There are 32Gb of free space left in an extended partition with which I
was attempting to carve 8Gb for a RHEL4/i386 install.  I selected the free
space area from the end of hdb, then chose "New", entered "8192" for size
in Mb, and chose "/" as mount point.  After hitting "ok" I got a parted
assertion dialog on screen, and logged to console which I'll attach
a digital picture of in a minute.


Version-Release number of selected component (if applicable):

Not sure what parted release is in RHEL4-U1-re0525.0-i386-AS-DVD-ftp.iso
quite yet...


How reproducible:

So far, I only attempted it once, however I have not completed the install,
so I will attempt to undo what was done and reproduce again.


Steps to Reproduce:
1. 2 hard disks in machine as hda and hdb.  Windows XP SP2 on hda as one
   massive NTFS partition, unused by Linux at all.
2. hdb is a drive dedicated to my Linux installs, and has 2 Linux installations
   on it, and 32Gb of free space in an extended partition.
3. Select empty space, select NEW, type in 8192 in size field, and "/" as
   mount point, hit OK.
  
Actual results:
parted Bug assertion, to be attached in digital photo shortly.

Expected results:
8Gb partition created with no error.  ;o)

Additional info:
This is an AMD64 Solo system, which I'm doing an i386 install of RHEL4U1 rc on,
however I doubt that is related to the problem.

Comment 1 Chris Lumens 2005-06-09 17:51:15 UTC
Could you attach the image containing the assertion?

Comment 2 Mike A. Harris 2005-06-13 14:52:41 UTC
Yes, will do.  I took digital pics, but my camera batteries died.  Having
a few other problems that will delay the pictures for a day or so, but I'll
update this when I get a chance.  Sorry for the delay.

Comment 3 Chris Lumens 2005-09-23 14:58:22 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.