Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1599034 - OSP8/9/10 upgrade fails because openstack-neutron-bgp-dragent cannot be upgraded.
Summary: OSP8/9/10 upgrade fails because openstack-neutron-bgp-dragent cannot be upgr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 10.0 (Newton)
Assignee: Nate Johnston
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-08 04:49 UTC by Sofer Athlan-Guyot
Modified: 2019-01-16 17:09 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.3.10-19
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 17:09:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0055 None None None 2019-01-16 17:09:52 UTC

Description Sofer Athlan-Guyot 2018-07-08 04:49:01 UTC
Description of problem: osp8/9/10 controller upgrade fails because of conflicting dependencies on the openstack-neutron-bgp-dragent package. 

This package doesn't exist anymore in osp10, and thus is kept in osp9 version with its own python neutron dependencies, preventing the yum upgrade command in step2 of the controller upgrade from succeeding.

This is related to https://bugzilla.redhat.com/show_bug.cgi?id=1421701 

Creating that bz to make sure we get it in osp10.

Comment 2 Sofer Athlan-Guyot 2018-07-19 13:14:48 UTC
Hi,

so unfortunately I don't have the exact error message.  Basically, it was complaining about python dependency that could not be resolve as the bgp package needed old python package from osp9 that were in conflict with new python package from osp10.

I guess to reproduce it, you simply have to install the bgp package, upgrade repo and try to yum upgrade it.

Comment 7 Nate Johnston 2018-09-18 15:33:23 UTC
Pushed a change to openstack-tripleo-heat-templates on the rhos-10.0-patches branch that should address this: https://code.engineering.redhat.com/gerrit/#/c/150427/

Comment 19 errata-xmlrpc 2019-01-16 17:09:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0055


Note You need to log in before you can comment on or make changes to this bug.