Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159901 - Add patch to fix bad domains when doing NTLM authentication against an Exchange server
Summary: Add patch to fix bad domains when doing NTLM authentication against an Exchan...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libsoup
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 156322 160071
TreeView+ depends on / blocked
 
Reported: 2005-06-08 22:15 UTC by Dave Malcolm
Modified: 2008-08-05 02:12 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-555
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 14:42:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:555 qe-ready SHIPPED_LIVE libsoup bug fix update 2005-10-05 04:00:00 UTC
GNOME Bugzilla 306877 None None None Never

Description Dave Malcolm 2005-06-08 22:15:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Upstream gnome bugs 302183 and 306877 report a problem (and a simple fix) when doing NTLM authentication using libsoup (used by evolution-connector package to talk to Exchnage servers).

Usernames of the form DOMAIN\USERNAME fail, due to libsoup getting confused about the domain to supply to the server in the type 3 NTLM message.

There's a simple fix, which should be evaluated for a RHEL4 update.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See upstream bug  

Additional info:

Comment 6 Dave Malcolm 2005-06-27 20:36:40 UTC
A version of the libsoup package for RHEL4 i386 with the fix is downloadable
from here:
http://people.redhat.com/dmalcolm/scratch/libsoup-2.2.1-2.i386.rpm

This was built in our regular build system, but hasn't been through QA.

Comment 14 Dave Malcolm 2005-09-01 17:45:20 UTC
See also bug #166627, which appears to be a separate problem in the NTLM
authentication code that will randomly cause failures on x86_64, with the same
visible symptoms to the user as this bug (it's a 64-bit cleanliness bug in the
code in libsoup and evolution-connector).


Comment 15 Red Hat Bugzilla 2005-10-05 14:42:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-555.html



Note You need to log in before you can comment on or make changes to this bug.