Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1599 - Login bug in wu-ftpd-2.4.2b18-2.1
Summary: Login bug in wu-ftpd-2.4.2b18-2.1
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-18 10:06 UTC by sweeheng
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-23 22:29:27 UTC


Attachments (Terms of Use)

Description sweeheng 1999-03-18 10:06:31 UTC
I am getting a perculiar behaviour from the
wu-ftpd-2.4.2b18-2.1.i386.rpm package downloaded from
updates.redhat.com. It is reproducible for me.

Scenario: I configured /etc/ftpaccess to allow only guest
accounts, ie. no real and anonymous access. I modified the
default ftpaccess file so that the first line reads:
     class guestuser   guest   *

To verify it, I ftp to my machine using various combinations
of real, guest and anonymous accounts. Almost every time it
works - real and anonymous users rejected while guest
admitted if password is right.

I said almost because if I do it in the following sequence,
I can get anonymous access:

1. FTP to machine;
2. Login as a *valid* guest user ("adam" in this example)
     Name(machine-name:someuser): adam <Enter>
     331 Password required for adam.
3. Provide blank/dummy password.
     Password: <Enter>
     530 Login incorrect.
4. Just as one would expect for the wrong password. However,
   immediately login as anonymous.
     ftp> user anonymous <enter>
     331 Guest login ok, send your complete ...<blah>
5. Give some random address.
     Password: someone@out.there <Enter>
     230 Guest login ok, access restriction apply.

Tada! I get anonymous access when I am not supposed to.

Seems like the first login as a valid guest user (but with
the wrong password) sets some flag which subsequently makes
ftpd forget the fact that anonymous access is not allowed.

I believe the wu-ftpd VR14 release have the same problem
too.

Comment 1 Jeff Johnson 1999-06-07 12:24:59 UTC
Commenting out the 1st class line in /etc/ftpaccess and adding
	class guestuser guest *
	guestuser adam
after adding user adam verifies that wu-ftpd-2.4.2vr17-3 has this
behavior also.

Comment 2 Jeff Johnson 1999-08-23 22:29:59 UTC
Fixed in wu-ftpd-2.5.0-5.


Note You need to log in before you can comment on or make changes to this bug.