Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159893 - yum upgrade shows conflicts in perl
Summary: yum upgrade shows conflicts in perl
Keywords:
Status: CLOSED DUPLICATE of bug 156288
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 21:18 UTC by Luke Schierer
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-08 22:56:47 UTC


Attachments (Terms of Use)

Description Luke Schierer 2005-06-08 21:18:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21 (Debian package 1.3.21-1+gnome28+1)

Description of problem:
having just finished a FC3 install on an x86_64 system, I went to upgrade it with yum.  the following transaction check error occured.  using --exclude=perl let everything else update, but even then this transaction check occurs if I cease to use --exclude=perl.

Transaction Check Error:   file /usr/lib/perl5/5.8.5/File/Path.pm from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/c2ph.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/find2perl.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/h2ph.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/h2xs.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/libnetcfg.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/perlbug.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/perlcc.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/perlivp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/piconv.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pl2pm.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pod2html.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pod2latex.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pod2man.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pod2text.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pod2usage.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/podchecker.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/podselect.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/prove.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/psed.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/pstruct.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/s2p.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/splain.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/xsubpp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9


Version-Release number of selected component (if applicable):
perl-5.8.5-9

How reproducible:
Always

Steps to Reproduce:
1. Install FC3
2. Run yum upgrade
3. see it fail
4. Run yum --exclude=perl
5. watch it work
6. run yum upgrade again
7. see it still fail. 
  

Actual Results:  see transaction check error above

Expected Results:  perl should upgrade

Additional info:

Comment 1 Warren Togami 2005-06-08 22:56:47 UTC
Sorry about the inconvenience.  We made a mistake when shipping FC3.  perl is
not a multilib package.  The only way to fix this is to use "rpm -e perl".


*** This bug has been marked as a duplicate of 156288 ***

Comment 2 Warren Togami 2005-06-09 05:57:05 UTC
Oops, I meant
rpm -e perl.i386



Note You need to log in before you can comment on or make changes to this bug.