Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159885 - Login and related cannot load libpam.so.0 after pam and db4 update
Summary: Login and related cannot load libpam.so.0 after pam and db4 update
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 20:34 UTC by Torrente B.
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-09 11:43:48 UTC


Attachments (Terms of Use)

Description Torrente B. 2005-06-08 20:34:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
After update with yum, the components pam-0.77-66.2.i386.rpm to pam-0.79-9.i386.rpm version and db4-4.2.52-6.i386.rpm to db4-4.3.27-4.i386.rpm version login and related functions / applications that use the library libpam.so.0 or libpam-misc.so.0 don't work on xdm nor text console and after reboot on a text console, typing the username and hitting enter, appear " /bin/login: error while loading shared libraries: libpam.so.0: cannot open share file. No such file or directory"

After trying to repair de problem booting with the rescue cd, if you try to execute other commands like reboot, shutdown, etc, or other apps that need's the libpam libraries or db4 functions, appears the same result.



Version-Release number of selected component (if applicable):
pam-0.79-9.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.On a running Fedora Core 4 Test 3 (3.92 release)system update pam and db4
2.
3.
  

Actual Results:  
The system remains unusable and can not reproduce.


Expected Results:  The running system due to work normally and making server functions as the last month after update mentioned files.

Additional info:

Last kernel downloadable with yum (1366)
System running environment up to date, June 6, with the main / core utilities & programs updated except these to packets pam & db4

Comment 1 Tomas Mraz 2005-06-09 06:59:16 UTC
What version of audit-libs do you have? If it's older than 0.8.1 could you try
to upgrade it?

If it doesn't help, are there any messages on login in /var/log/secure and
/var/log/messages?


Comment 2 Torrente B. 2005-06-09 10:55:48 UTC
After testing the audit-libs and audit version (was 0.7.3-2) i manually download
and update to 0.9.2-1 version.
Don't work by the same way, but re-updating pam and db4 (the same version that
have fedora core 3, 4.2.52-6 for db4 and 0.77-66.2 for pam) to the developement
version 4.3.27-4 and 0.79-9 respectively, after rebooting work properly.

Thank you very much Tomas Mraz.


P.S.: logs before solution don't provide useful info.
Maybe will useful update pam and db4 dependencies for this issue.


Comment 3 Tomas Mraz 2005-06-09 11:43:48 UTC
The dependency on audit-libs>=0.8.1 is missing in the pam package. It will be
added in the next update.


Comment 4 Torrente B. 2005-06-10 21:28:02 UTC
After 24h working only remains slightly problem with the audit tool. Some error
messages appears during boot - starting sevices.


Note You need to log in before you can comment on or make changes to this bug.