Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159879 - sendmail bad file descriptor error upstream patched
Summary: sendmail bad file descriptor error upstream patched
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL: http://www.issociate.de/board/post/18...
Whiteboard:
Depends On:
Blocks: 200922
TreeView+ depends on / blocked
 
Reported: 2005-06-08 19:36 UTC by Need Real Name
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-24 13:26:23 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-06-08 19:36:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050201 Firefox/1.0+ (PowerBook)

Description of problem:
There's a bug in 8.12.11 that was fixed upstream in 8.13.2. The release notes describe it best:

	If a server returns a 421 reply to the RSET command between
		message deliveries, do not attempt to deliver any more
		messages on that connection.  This prevents bogus "Bad
		file number" recipient status.  Problem noted by
		Allan E Johannesen of Worcester Polytechnic Institute.

(http://www.sendmail.org/ftp/RELEASE_NOTES)

Version-Release number of selected component (if applicable):
8.12.11

How reproducible:
Always

Steps to Reproduce:
1. Try to send 2 mails to an address @aol.com from a host with no reverse DNS
2. Observe the first one rejected properly with a 421, the second with a "Deferred: Bad file descriptor" status.
3.
  

Actual Results:  See above

Expected Results:  the second mail should have a "Deferred: 421..." status instead

Additional info:

It's fixed upstream, please just incorporate their fix.

Comment 1 Thomas Woerner 2007-07-24 13:26:23 UTC
I am sorry, but the fix is very large, because it has to get fixed in several
parts of sendmail. Even 8.14.0 still contains fixes for 421 returns.
Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.