Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1598569 - can not create host - Error: lifecycle_environment not found.
Summary: can not create host - Error: lifecycle_environment not found.
Keywords:
Status: CLOSED DUPLICATE of bug 1583597
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jan Hutař
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 20:17 UTC by Jan Hutař
Modified: 2018-07-17 12:04 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-17 12:04:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
full output of hammer command (deleted)
2018-07-05 20:18 UTC, Jan Hutař
no flags Details
foreman-debug (deleted)
2018-07-05 20:47 UTC, Jan Hutař
no flags Details

Description Jan Hutař 2018-07-05 20:17:03 UTC
Description of problem:
I can not create host. I says "Error: lifecycle_environment not found." enen when I provide it.


Version-Release number of selected component (if applicable):
satellite-6.4.0-9.beta.el7sat.noarch (snap 10)


How reproducible:
always


Steps to Reproduce:
1. # hammer -d -v -u admin -p changeme --output=csv host create --architecture-id="1" --domain-id="5" --environment="KT_iaEeE4_Library_xODchtIMtj_11" --ip="215.4.103.159" --location-id="2" --mac="10:9c:0f:ac:fe:cf" --medium-id="13" --name="RYXQNwUawm" --operatingsystem-id="2" --organization-id="9" --partition-table-id="94" --root-password="pkNKvAjF" --lifecycle-environment-id 12


Actual results:
Could not create the host:
  Error: lifecycle_environment not found.


Expected results:
Should work

Comment 1 Jan Hutař 2018-07-05 20:18:06 UTC
Created attachment 1456836 [details]
full output of hammer command

Comment 2 Jan Hutař 2018-07-05 20:19:17 UTC
The LE 12 should be completely OK (available in org 9):

[root@sat640snap10 ~]# hammer -v -u admin -p changeme lifecycle-environment list --organization-id="9"
---|---------|--------
ID | NAME    | PRIOR  
---|---------|--------
12 | aaa     | Library
10 | Library |        
11 | zNTppZ  | Library
---|---------|--------

Comment 5 Jan Hutař 2018-07-05 20:47:03 UTC
Created attachment 1456839 [details]
foreman-debug

Comment 10 Roman Plevka 2018-07-17 12:04:16 UTC

*** This bug has been marked as a duplicate of bug 1583597 ***


Note You need to log in before you can comment on or make changes to this bug.