Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1598412 - libvirtd crash on target Power9 host when migration from RHEL-7.5 to RHEL-ALT-7.6 with --tls
Summary: libvirtd crash on target Power9 host when migration from RHEL-7.5 to RHEL-ALT...
Keywords:
Status: CLOSED DUPLICATE of bug 1598015
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.6-Alt
Hardware: ppc64le
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 11:54 UTC by Dan Zheng
Modified: 2018-07-09 07:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-09 07:40:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
libvirtd crash on target P9 host (deleted)
2018-07-05 11:54 UTC, Dan Zheng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1598015 None None None Never

Internal Links: 1598015

Description Dan Zheng 2018-07-05 11:54:50 UTC
Created attachment 1456757 [details]
libvirtd crash on target P9 host

Description of problem:
Libvirtd daemon crashed on target Power9 host when do migration from RHEL-7.5 Power8 to RHEL-ALT-7.6 Power9 using --tls option. The crash does not happen from  RHEL-7.5 Power8 to RHEL-7.6 Power8 using --tls option.

Version-Release number of selected component (if applicable):

Source host:
Power 8: RHEL-7.5-20180322.0
kernel: 3.10.0-862.el7.ppc64le
qemu-kvm-rhev-2.10.0-21.el7_5.4.ppc64le
libvirt-3.9.0-14.virtcov.el7_5.6.ppc64le

Target host:
Power 9: RHEL-ALT-7.6-20180626.3
kernel: 4.14.0-87.el7a.ppc64le
qemu-kvm-rhev-2.12.0-6.el7.ppc64le
libvirt-4.5.0-1.el7.ppc64le

How reproducible:
100%

Steps to Reproduce:
1. Setup TLS server and client environment
2. Modify migrate_tls_x509_verify = 1 in /etc/libvirt/qemu.conf
3. Run migration:
 /bin/virsh -c 'qemu:///system' migrate --live --verbose --domain avocado-vt-vm1 --desturi qemu+ssh://<Power9_target_host>/system --tls

Actual results:
Ncat: Broken pipe.: Input/output error
Libvirtd on target host is crashed.

Expected results:
Migration succeeds and no libvirtd crash.

Additional info:
See attachment for gdb log.

Comment 2 Dan Zheng 2018-07-06 05:57:38 UTC
From the automated job log, I can see libvirt-4.4.0-2.el7.ppc64le has not this issue.

Comment 3 Peter Krempa 2018-07-09 07:40:06 UTC
#0  virJSONValueObjectGet (object=0x0, key=0x7fff71b99a80 "qom-type") at util/virjson.c:818
#1  0x00007fff83d67ea8 in virJSONValueObjectGetString (object=<optimized out>, key=<optimized out>) at util/virjson.c:1258
#2  0x00007fff71b0d0e8 in qemuMonitorAddObject (mon=0x7fff5800a850, props=0x7fff7aaada80, alias=<optimized out>) at qemu/qemu_monitor.c:3090
#3  0x00007fff71accc28 in qemuDomainAddTLSObjects (driver=0x7fff2c0f7630, vm=0x7fff58003d50, asyncJob=<optimized out>, secProps=0x7fff7aaada80, tlsProps=0x7fff7aaada78) at qemu/qemu_hotplug.c:1342
#4  0x00007fff71b011dc in qemuMigrationParamsEnableTLS (driver=0x7fff2c0f7630, vm=0x7fff58003d50, tlsListen=<optimized out>, asyncJob=<optimized out>, tlsAlias=0x7fff7aaadc88, hostname=0x0, 
    migParams=0x7fff58001f80) at qemu/qemu_migration_params.c:878

*** This bug has been marked as a duplicate of bug 1598015 ***


Note You need to log in before you can comment on or make changes to this bug.