Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1598367 - evmserverd fails to start with error "could not find nokogiri-1.8.1 in any of the sources (Bundler::GemNotFound)" [NEEDINFO]
Summary: evmserverd fails to start with error "could not find nokogiri-1.8.1 in any of...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Joe Rafaniello
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 08:40 UTC by Prasad Mukhedkar
Modified: 2018-08-01 14:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 17:00:54 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
jrafanie: needinfo? (pmukhedk)
jrafanie: needinfo? (pmukhedk)


Attachments (Terms of Use)
rpm_package_working_appliance (deleted)
2018-07-05 08:41 UTC, Prasad Mukhedkar
no flags Details
rpm_package_nonworking_appliance (deleted)
2018-07-05 08:42 UTC, Prasad Mukhedkar
no flags Details
rpm_verification_nonworking_appliance (deleted)
2018-07-05 08:42 UTC, Prasad Mukhedkar
no flags Details
gemfile non-working (deleted)
2018-07-05 08:44 UTC, Prasad Mukhedkar
no flags Details
gemfile working (deleted)
2018-07-05 08:47 UTC, Prasad Mukhedkar
no flags Details

Comment 2 Prasad Mukhedkar 2018-07-05 08:41:11 UTC
Created attachment 1456697 [details]
rpm_package_working_appliance

Comment 3 Prasad Mukhedkar 2018-07-05 08:42:24 UTC
Created attachment 1456698 [details]
rpm_package_nonworking_appliance

Comment 4 Prasad Mukhedkar 2018-07-05 08:42:58 UTC
Created attachment 1456699 [details]
rpm_verification_nonworking_appliance

Comment 5 Prasad Mukhedkar 2018-07-05 08:44:11 UTC
Created attachment 1456700 [details]
gemfile non-working

Comment 6 Prasad Mukhedkar 2018-07-05 08:47:54 UTC
Created attachment 1456701 [details]
gemfile working

Comment 9 Joe Rafaniello 2018-07-19 16:02:04 UTC
Hi Prasad, I deployed a 5.7.3.2 appliance, configured the db, started it up...
registered with subscription-manager, enabled the SCL, OS, and cfme repos... then did a yum update cfme-appliance.  It updated to 5.7.4.3, one patch level after yours.  Additionally, it installed ruby 2.3.6 instead of 2.3.1 in your case.

I then exited my shell and ssh'd in and was able to run appliance_console, bundle show nokogiri, etc.

I'm not sure why they hit this issue but perhaps the upgrade from scl ruby 2.3.1 to 2.3.6 on my system is a key difference.  Can you verify their satellite is up to date with packages and try to yum update cfme-appliance again?

Jul 19 10:54:38 Updated: libtalloc-2.1.10-1.el7.x86_64
Jul 19 10:54:39 Updated: rh-ruby23-ruby-libs-2.3.6-67.el7.x86_64
Jul 19 10:54:39 Updated: libtevent-0.9.33-2.el7.x86_64
Jul 19 10:54:39 Updated: libtdb-1.3.15-1.el7.x86_64
Jul 19 10:54:39 Updated: krb5-libs-1.15.1-19.el7.x86_64
Jul 19 10:54:39 Updated: samba-common-4.7.1-6.el7.noarch
Jul 19 10:54:40 Installed: rh-nodejs6-runtime-2.4-6.el7.x86_64
Jul 19 10:54:40 Updated: libldb-1.2.2-1.el7.x86_64
Jul 19 10:54:40 Installed: samba-common-libs-4.7.1-6.el7.x86_64
Jul 19 10:54:40 Updated: libwbclient-4.7.1-6.el7.x86_64
Jul 19 10:54:41 Updated: samba-client-libs-4.7.1-6.el7.x86_64
Jul 19 10:54:41 Updated: rh-ruby23-ruby-irb-2.3.6-67.el7.noarch
Jul 19 10:54:41 Updated: rh-ruby23-ruby-2.3.6-67.el7.x86_64
Jul 19 10:54:41 Updated: rh-ruby23-rubygem-rdoc-4.2.1-67.el7.noarch
Jul 19 10:54:41 Updated: rh-ruby23-rubygems-2.5.2.2-67.el7.noarch
Jul 19 10:54:41 Updated: rh-ruby23-rubygem-psych-2.1.0.1-67.el7.x86_64
Jul 19 10:54:41 Updated: rh-ruby23-rubygem-nokogiri-1.8.1-2.el7cf.x86_64
Jul 19 10:54:51 Updated: cfme-gemset-5.7.4.3-1.el7cf.x86_64
Jul 19 10:54:51 Installed: 1:rh-nodejs6-libuv-1.9.1-3.el7.x86_64
Jul 19 10:54:51 Installed: rh-nodejs6-http-parser-2.7.0-4.el7.x86_64
Jul 19 10:54:52 Installed: rh-nodejs6-nodejs-6.11.3-6.el7.x86_64
Jul 19 10:55:09 Updated: cfme-5.7.4.3-1.el7cf.x86_64
Jul 19 10:55:10 Updated: libkadm5-1.15.1-19.el7.x86_64
Jul 19 10:55:10 Installed: pytalloc-2.1.10-1.el7.x86_64
Jul 19 10:55:10 Installed: samba-libs-4.7.1-6.el7.x86_64
Jul 19 10:55:10 Installed: samba-common-tools-4.7.1-6.el7.x86_64
Jul 19 10:55:10 Updated: cfme-appliance-5.7.4.3-1.el7cf.x86_64
Jul 19 10:55:10 Updated: krb5-workstation-1.15.1-19.el7.x86_64
Jul 19 10:55:10 Updated: libsmbclient-4.7.1-6.el7.x86_64

Comment 12 Joe Rafaniello 2018-07-31 17:00:54 UTC
Prasad, I'm closing this for now.  Please reopen when we have more information.  Something is very strange.  I'm not sure if there's cached yum data or something else going on but the yum dependency tree for the same version appliances should be identical.  See comment #11 and comment #9 where it worked for me.  I'm not sure what else to look at on this problematic appliance.  Let me know what you find out and we can reopen if needed.


Note You need to log in before you can comment on or make changes to this bug.