Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159834 - %config(noreplace) %attr does not create a .rpmnew
Summary: %config(noreplace) %attr does not create a .rpmnew
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm
Version: 3.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 15:18 UTC by Mauricio Gomes
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-01 10:09:11 UTC


Attachments (Terms of Use)

Description Mauricio Gomes 2005-06-08 15:18:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
%config(noreplace) files that have had an %attr change from one release to another do not create .rpmnew files when modified configuration files are present.  The .rpmnew is only created if the %config(noreplace) file is different between releases.  This results in file attribute changes not being applied in anyway until the configuration file, included in the package, is specifically modified.  Bugs related to permission changes therefore requires developers to modify configuration files between releases in some way in order for attribute changes to get applied. 

Version-Release number of selected component (if applicable):
rpm-4.2.3-21_nonptl, rpm-4.3.3-9_nonptl; tested

How reproducible:
Always

Steps to Reproduce:
1. Change a %config(noreplace) file to have new attributes, but do not modify the configuration.

2. Update (rpm -Uvh) to the new release.

3. Examine the directory of the configuration file for permission changes or the existence of a .rpmnew file.
  

Actual Results:  The configuration file still has the old permissions and no .rpmnew file exists for that file.

Expected Results:  A .rpmnew file should be created, if the configuration has been modified, with the correct permissions set.

Additional info:

Workaround is to add blank spaces or comments to a configuration file in order for the new permissions to take effect.

Comment 1 Jeff Johnson 2005-07-01 10:09:11 UTC
Yes. If the locally installed file is unchanged wrto the old package, then a %config(noreplace) file
is installed on the original, not a *.rpmnew, path.

Comment 2 Mauricio Gomes 2005-07-07 01:54:10 UTC
You have misunderstood what I stated above.  What I am saying is that when Red Hat released packages 
because config files have incorrect permissions and end users have modified their config files, then 
a .rpmew file is NOT created.  This is incorrect behavior because a system administrator needs to know 
what the new permissions are, and he cannot do so unless a .rpmnew file is created.  Please reopen this 
bug.


Note You need to log in before you can comment on or make changes to this bug.