Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1598316 - Failed to update qemu-kvm-tools-rhev
Summary: Failed to update qemu-kvm-tools-rhev
Keywords:
Status: CLOSED DUPLICATE of bug 1598104
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 06:20 UTC by yafu
Modified: 2018-07-05 06:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-05 06:27:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description yafu 2018-07-05 06:20:59 UTC
Description of problem:
Failed to update qemu-kvm-tools-rhev-2.12.0-6.el7.x86_64 to qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64:
Transaction check error:
  file /usr/share/man/man1/kvm_stat.1.gz from install of qemu-kvm-tools-rhev-10:2.12.0-7.el7.x86_64 conflicts with file from package qemu-kvm-tools-rhev-10:2.12.0-6.el7.x86_64

Version-Release number of selected component (if applicable):
qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.#yum -y update http://download.eng.bos.redhat.com/brewroot/packages/qemu-kvm-rhev/2.12.0/7.el7/x86_64/qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64.rpm
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64.rpm                                                                                    | 422 kB  00:00:01     
Examining /var/tmp/yum-root-7SK1M7/qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64.rpm: 10:qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64
Marking /var/tmp/yum-root-7SK1M7/qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64.rpm as an update to 10:qemu-kvm-tools-rhev-2.12.0-6.el7.x86_64
Resolving Dependencies
--> Running transaction check
---> Package qemu-kvm-tools-rhev.x86_64 10:2.12.0-6.el7 will be updated
---> Package qemu-kvm-tools-rhev.x86_64 10:2.12.0-7.el7 will be an update
--> Processing Dependency: libxkbcommon.so.0(V_0.5.0)(64bit) for package: 10:qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64
--> Processing Dependency: libxkbcommon.so.0()(64bit) for package: 10:qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64
--> Running transaction check
---> Package libxkbcommon.x86_64 0:0.7.1-1.el7 will be installed
--> Processing Dependency: xkeyboard-config for package: libxkbcommon-0.7.1-1.el7.x86_64
--> Running transaction check
---> Package xkeyboard-config.noarch 0:2.24-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                           Arch                 Version                          Repository                                              Size
======================================================================================================================================================
Updating:
 qemu-kvm-tools-rhev               x86_64               10:2.12.0-7.el7                  /qemu-kvm-tools-rhev-2.12.0-7.el7.x86_64               516 k
Installing for dependencies:
 libxkbcommon                      x86_64               0.7.1-1.el7                      beaker-Server                                          108 k
 xkeyboard-config                  noarch               2.24-1.el7                       beaker-Server                                          834 k

Transaction Summary
======================================================================================================================================================
Install             ( 2 Dependent packages)
Upgrade  1 Package

Total size: 1.4 M
Total download size: 942 k
Downloading packages:
(1/2): libxkbcommon-0.7.1-1.el7.x86_64.rpm                                                                                     | 108 kB  00:00:00     
(2/2): xkeyboard-config-2.24-1.el7.noarch.rpm                                                                                  | 834 kB  00:00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                 8.2 MB/s | 942 kB  00:00:00     
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/man/man1/kvm_stat.1.gz from install of qemu-kvm-tools-rhev-10:2.12.0-7.el7.x86_64 conflicts with file from package qemu-kvm-tools-rhev-10:2.12.0-6.el7.x86_64

Error Summary
-------------


Actual results:
Failed to update qemu-kvm-tools-rhev

Expected results:
Update qemu-kvm-tools-rhev successfully.

Additional info:

Comment 2 juzhang 2018-07-05 06:23:53 UTC
Hi Yafu,

Seems it's duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1598104? Can you check?

Best Regards,
Junyi

Comment 3 yafu 2018-07-05 06:27:30 UTC
(In reply to juzhang from comment #2)
> Hi Yafu,
> 
> Seems it's duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1598104?
> Can you check?
> 
> Best Regards,
> Junyi

Yes, it's the same issue. I will close this bug. Thanks.

*** This bug has been marked as a duplicate of bug 1598104 ***


Note You need to log in before you can comment on or make changes to this bug.