Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159821 - --freshen ignores --oldpackage
Summary: --freshen ignores --oldpackage
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 10:31 UTC by Andrew Benham
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-12 15:45:26 UTC


Attachments (Terms of Use)

Description Andrew Benham 2005-06-08 10:31:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When using 'rpm --freshen --oldpackage', the '--oldpackage' argument is silently ignored.
E.g. if one has 'wibble-1.2' installed, 'rpm --freshen --oldpackage wibble-1.1'
will exit with a return code of 0 BUT will not have replaced 'wibble-1.2' with 'wibble-1.1'.
This is REALLY bad, because the behaviour of the program does not meet the user's expected behaviour. It violates the principal of least astonishment.

Version-Release number of selected component (if applicable):
rpm-4.3.2-21

How reproducible:
Always

Steps to Reproduce:
1. Install package
2. Attempt to 'rpm --freshen --oldpackage' with older version of package
  

Actual Results:  Package NOT freshened.

Expected Results:  Something else. The actual result is VERY non-intuitive.
You maintain RPM, you get to choose the expected result from the following list:
1/.  Packaged freshed with older package
or
2/.  Fatal error "you cannot use '--oldpackage' with '--freshen'. Use '--upgrade' instead"

Additional info:

Comment 1 Jeff Johnson 2006-02-12 15:45:26 UTC
The two options have incompatible meanings. The --freshen option
checks for existence of a newer package if already installed, while --oldpackage
permits downgrades.

Comment 2 Andrew Benham 2006-02-13 09:52:26 UTC
(In reply to comment #1)
> The two options have incompatible meanings. The --freshen option
> checks for existence of a newer package if already installed, while --oldpackage
> permits downgrades.

Yes, OK, agreed.

So don't return "success" when the command hasn't been successful.



Note You need to log in before you can comment on or make changes to this bug.