Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 159820 - usb-storage automount only works once
Summary: usb-storage automount only works once
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-08 10:21 UTC by Menno Smits
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 11:56:44 UTC


Attachments (Terms of Use)

Description Menno Smits 2005-06-08 10:21:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
The first time I plug in a usb-storage device it is detected and automounts correctly. If I umount the device, unplug it and plug it back in, it will be detected but will not automount.

I see this problem with a iPod (on USB) and a USB memory stick.

This problem did not occur in Fedora Core 3 with the same devices and same PC hardware.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1286_FC4

How reproducible:
Always

Steps to Reproduce:
1. Start from a fresh reboot and login.
2. Plug-in a USB storage device.
3. Wait for device's icon to appear.
4. Umount the device (either via the command line or through Gnome).
5. Unplug the device and plug it back in.

  

Actual Results:  Device is not auto-mounted the second time and subsequent times. No device icon appears on the desktop but logs indicate the device is detected ok.

At this point mounting the device manually (eg. mount /dev/sda2 /mnt/ipod) does work and causes an icon to appear on the desktop. The device can then be used.


Expected Results:  The usb-storage device should automount each time it is plugged in.

Additional info:

I've found that uninstalling the usb-storage driver (modprobe -r usb-storage) and then plugging a usb-storage device back in will result in automount working, again just for one time. 

If I use the eject command to umount the device or select Unmount Volume in Gnome GUI I receive an error like: "eject: unable to open `/dev/sda2' in dialog" although the umount seems to work. If I just use umount on the command line I don't see any errors. Not sure if this is related but thought I'd mention it.

Comment 1 Menno Smits 2005-06-15 11:56:44 UTC
Seems to be fixed in FC4.


Note You need to log in before you can comment on or make changes to this bug.