Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1598031 - Tuned fails to isolate the pmd processes with regex by using tuned scheduler [rhel-7.5.z]
Summary: Tuned fails to isolate the pmd processes with regex by using tuned scheduler ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
Marek Suchanek
URL:
Whiteboard:
: 1601350 (view as bug list)
Depends On: 1512295
Blocks: 1599730 1601000 1601001
TreeView+ depends on / blocked
 
Reported: 2018-07-04 07:56 UTC by Oneata Mircea Teodor
Modified: 2018-08-16 14:20 UTC (History)
15 users (show)

Fixed In Version: tuned-2.9.0-1.el7_5.1
Doc Type: Bug Fix
Doc Text:
Previously, Tuned migrated threads during cores isolation even if you blacklisted the threads from being migrated. With this update, the scheduler plug-in has been fixed to filter thread names through the same blacklist and whitelist filters as process names. As a result, Tuned no longer migrates black listed threads.
Clone Of: 1512295
Environment:
Last Closed: 2018-08-16 14:20:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2456 None None None 2018-08-16 14:20:29 UTC

Description Oneata Mircea Teodor 2018-07-04 07:56:02 UTC
This bug has been copied from bug #1512295 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 6 Yariv 2018-07-12 12:15:17 UTC
Veified with puddle OpenStack-13.0-RHEL-7-20180710.3
Kernel 3.10.0-862.6.3.el7 
Tuned http://download.eng.bos.redhat.com/brewroot/packages/tuned/2.9.0/1.el7_5.1/noarch/tuned-2.9.0-1.el7_5.1.noarch.rpm

Did restart to compute, pmd threads were not evacuated

Comment 11 Oneata Mircea Teodor 2018-07-16 07:58:40 UTC
*** Bug 1601350 has been marked as a duplicate of this bug. ***

Comment 16 errata-xmlrpc 2018-08-16 14:20:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2456


Note You need to log in before you can comment on or make changes to this bug.