Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597943 - gr-fecs not built or packaged due to spec file error
Summary: gr-fecs not built or packaged due to spec file error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gnuradio
Version: epel7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-04 01:45 UTC by sayguh
Modified: 2018-07-31 19:03 UTC (History)
3 users (show)

Fixed In Version: gnuradio-3.7.11-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 19:03:55 UTC


Attachments (Terms of Use)

Description sayguh 2018-07-04 01:45:13 UTC
Description of problem: The gr-fecs module of gnuradio is not built or packaged because cmake has no way to find the required GSL dependency. GnuRadio has a FindGSL.cmake file however the spec file removes it. The spec file author commented that it should "Use cmake's FindGSL.cmake instead" however the default RHEL7 version of cmake has no FindGSL.cmake file.


Version-Release number of selected component (if applicable): 3.7.11-6


How reproducible: Install gnuradio, note that none of the fec related packages are present.

Actual results:
Missing fec files, ex.: /usr/lib64/python2.7/site-packages/gnuradio/fec/*

Expected results:
FEC module packaged and installed.


Additional info:
The only changes necessary are to the spec file to remove the deletion of the FindGSL.cmake file (and an update to release and changelog).

--- orig/gnuradio.spec	2017-09-15 09:18:31.000000000 -0400
+++ new/gnuradio.spec	2018-07-03 20:13:06.070275287 -0400
@@ -24,7 +24,7 @@
 
 Name:		gnuradio
 Version:	3.7.11
-Release:	6%{?alphatag:.%{alphatag}}%{?dist}
+Release:	7%{?alphatag:.%{alphatag}}%{?dist}
 Summary:	Software defined radio framework
 
 Group:		Applications/Engineering
@@ -108,9 +108,6 @@
 %patch1 -p1 -b .gcc-7-compile-fix
 %patch2 -p1 -b .boost-atomic-compile-fix
 
-# Use cmake's FindGSL.cmake instead
-rm cmake/Modules/FindGSL.cmake
-
 #force regeneration of cached moc output files
 find . -name "*_moc.cc" -exec rm {} \;

Comment 1 Fedora Update System 2018-07-10 21:38:39 UTC
gnuradio-3.7.11-7.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d81c0f2181

Comment 2 Fedora Update System 2018-07-11 19:51:14 UTC
gnuradio-3.7.11-7.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d81c0f2181

Comment 3 Fedora Update System 2018-07-31 19:03:55 UTC
gnuradio-3.7.11-7.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.