Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1597886 - vdo growPhysical command on non-expanded device no longer prints message regarding lack of additional space
Summary: vdo growPhysical command on non-expanded device no longer prints message rega...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Sakai
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On: 1576539
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-03 19:55 UTC by Bryan Gurney
Modified: 2018-10-30 09:40 UTC (History)
4 users (show)

Fixed In Version: 6.1.1.108
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 09:39:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3094 None None None 2018-10-30 09:40:14 UTC

Description Bryan Gurney 2018-07-03 19:55:41 UTC
Description of problem:


Version-Release number of selected component (if applicable):
kmod-kvdo-6.1.1.99-1.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Create a VDO volume on a device.
2. Without increasing the size of the device, run "vdo growPhysical --name=vdo1"

Actual results:
Messages appear indicating an "Invalid argument" being sent from the device, but no indication as to the root cause.

vdo: ERROR - Cannot prepare to grow physical on VDO vdo1; device-mapper: message ioctl on vdo1  failed: Invalid argument
vdo: ERROR - device-mapper: message ioctl on vdo1  failed: Invalid argument


Expected results:
A message in the kernel log indicating that the physical block count is not larger than its previous size.  Example from kmod-kvdo-6.1.0.153-15.el7.x86_64:
"kernel: kvdo35:dmsetup: Requested physical block count 26214144 not greater than 26214144"

Additional info:

Full command examples from an example for a 100 GB partition:

RHEL 7.6 example:

[root@localhost ~]# uname -r; rpm -qa kmod-kvdo vdo
3.10.0-915.el7.x86_64
kmod-kvdo-6.1.1.99-1.el7.x86_64
vdo-6.1.1.99-2.el7.x86_64
[root@localhost ~]# date; vdo growPhysical --name=vdo1
Tue Jul  3 15:41:18 EDT 2018
vdo: ERROR - Cannot prepare to grow physical on VDO vdo1; device-mapper: message ioctl on vdo1  failed: Invalid argument
vdo: ERROR - device-mapper: message ioctl on vdo1  failed: Invalid argument
[root@localhost ~]# tail /var/log/messages
...
Jul  3 15:41:18 localhost kernel: kvdo2:dmsetup: Preparing to resize physical to 26214144
Jul  3 15:41:18 localhost vdo: ERROR - Cannot prepare to grow physical on VDO vdo1; device-mapper: message ioctl on vdo1  failed: Invalid argument
Jul  3 15:41:18 localhost vdo: ERROR - device-mapper: message ioctl on vdo1  failed: Invalid argument


RHEL 7.5 example:

[root@localhost ~]# uname -r; rpm -qa kmod-kvdo vdo
3.10.0-862.el7.x86_64
kmod-kvdo-6.1.0.153-15.el7.x86_64
vdo-6.1.0.149-16.x86_64
[root@localhost ~]# date; vdo growPhysical --name=vdo1
Tue Jul  3 15:41:39 EDT 2018
vdo: ERROR - Cannot grow physical on VDO vdo1; device-mapper: message ioctl on vdo1  failed: Invalid argument
vdo: ERROR - device-mapper: message ioctl on vdo1  failed: Invalid argument
[root@localhost ~]# tail /var/log/messages
...
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: Preparing to resize physical to 26214144
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: Done preparing to resize physical
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: suspending device 'vdo1' 
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: device 'vdo1' suspended
Jul  3 15:41:39 localhost vdo: ERROR - Cannot grow physical on VDO vdo1; device-mapper: message ioctl on vdo1  failed: Invalid argument
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: Requested physical block count 26214144 not greater than 26214144
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: resuming device 'vdo1'
Jul  3 15:41:39 localhost kernel: kvdo35:dmsetup: device 'vdo1' resumed
Jul  3 15:41:39 localhost vdo: ERROR - device-mapper: message ioctl on vdo1  failed: Invalid argument

Comment 2 Bryan Gurney 2018-07-03 19:57:52 UTC
Description of problem:

If the user tries to run "vdo growPhysical" on a VDO volume without having increased the size of the backing device, they will receive a message stating "message ioctl on <volume> failed: Invalid argument", without a helpful kernel log message regarding the reason why the growPhysical attempt failed (i.e.: the requested physical block count did not increase).

Comment 3 Jakub Krysl 2018-07-04 06:45:07 UTC
I think the reduced number of messages in /var/log/messages is caused by fix in BZ 1576539.
The rest being asked in this BZ is already being asked in BZ 1512134 (exposing the messages), except here we have 0 growth and in BZ 1512134 it is growth too small.
Matthew is it the fix the same for this BZ and BZ 1512134 (so we should close this a dup) or is it different?

Comment 6 Matthew Sakai 2018-07-05 21:36:25 UTC
Jakub, I think you are correct that is a side-effect of the way we fixed BZ 1576539.
BZ 1512134 is about exposing the error message through the user management script instead of only through log messages. This BZ is about having sufficient information in the log messages. So, I believe they are different and I will fix this one shortly.

Comment 8 Jakub Krysl 2018-07-18 11:05:17 UTC
kmod-kvdo-6.1.1.111-1.el7:

# vdo growPhysical --name=vdo --verbose
    vdodumpconfig /dev/disk/by-id/scsi-3600140550ade793f6124ab5b420f3c20-part1
    dmsetup status vdo
    dmsetup resume vdo
    vdodmeventd -r vdo
    dmsetup status vdo
    dmsetup message vdo 0 prepareToGrowPhysical
vdo: ERROR - Cannot prepare to grow physical on VDO vdo; device-mapper: message ioctl on vdo  failed: Invalid argument
vdo: ERROR - device-mapper: message ioctl on vdo  failed: Invalid argument


/var/log/messages:
[165807.507587] kvdo85:dmsetup: Preparing to resize physical to 19660544
[165807.539492] kvdo85:dmsetup: Requested physical block count 19660544 not greater than 19660544

Comment 10 errata-xmlrpc 2018-10-30 09:39:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3094


Note You need to log in before you can comment on or make changes to this bug.